Premium support

Please log in to post in these forums. If you didn't create an account when you purchased, please contact us.

Free support

If you haven't purchased GP Premium, support for the free theme can be found on WordPress.org.

[Resolved] Woocommerce images not showing

Home Forums Support Woocommerce images not showing

This topic contains 22 replies, has 4 voices, and was last updated by  Tom 8 months ago.

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #384106

    hi,
    I cant find the problem why woocommerce images are not showing.
    maybe you can help me.
    after changing the theme the catalogue images werent displayed anymore.
    at first I thought I can use regenerate thumbnails to recover them,but it didnt work.
    all the products were imported via Woozone and have a file url like this: (in my media library)
    https://images-eu.ssl-images-amazon.com/images/

    the single product page works fine. no problems there.
    I cleared my browser cache and tried few things but no success.

    here is the site

    thanks

    GP Premium 1.4.3
    #384158

    Leo
    Customer Support

    Hi there,

    Is Displaying product image checked in the customizer? https://docs.generatepress.com/article/woocommerce-overview/#shop

    #384196

    yes,first thing I checked were woocommerce settings.
    I imported new products to check if these images are showing but they doesnt show either.

    #384209

    .

    #384265

    Leo
    Customer Support

    Can you try disabling Elementor on that page?

    #384500

    still the same.

    yesterday I tried several free themes.
    one theme showed very small thumbnails,one showed them on hover and the rest didnt show catalogue images.

    I guess I have to restore the site back to when it worked and check step by step where the problem is.

    #384542

    David
    Customer Support

    Your images are hosted on amazon which is generating a 403 forbidden error. You may want to check your settings there

    #384576

    ok,how and where do I do that?

    #384734

    Tom
    Lead Developer

    It’s either a setting inside your Amazon server, or on your website server (not allowing hotlinked images).

    #384797

    I reinstalled avada and the catalogue images are displayed again so it has to be something within the GP theme and other themes that are not optimized for woocommerce or woozone. (there is something off with the hover image but I wont fix it for now)
    I let avada installed for you guys so you can maybe figure out where the problem is.
    I really dont want to go back to avada because its slow and I dont like it in general.

    storefront also kinda works when I hover over the product and its a woocommerce theme I think.

    oh btw: the rest of the site is private bc the site is not on yet.

    #385009

    Tom
    Lead Developer

    GP doesn’t actually have any say over displaying the images – that’s 100% WooCommerce. The fact that you’re getting 403 forbidden errors (right click in Chrome + Inspect to see them) means this is likely a server issue. Maybe there’s something in Avada overriding it?

    #385133

    the single product shows the images and these images are also from amazon. why is there a difference between the single product page and the catalogue?
    if it has to do with my site settings,I dont know where to change it.
    I’m a beginner and just started with wordpress.
    isnt there a way to show the image that is displayed on the single product page ,to get it to display in the catalogue as a thumbnail?

    BTW: avada uses !important all the time in CSS.maybe they use the same methods in coding?using commands to override/prioritize certain things to get the result they want?

    anyway,I hope you can help me to display the catalogue images.if you give me advice,please be as specific as possible?I just started 4 weeks ago.

    #385417

    Tom
    Lead Developer

    I’m afraid I don’t really have an answer – I’m sorry! The issue is the 403 forbidden errors, so your next step would be contacting your hosting as 403 errors are a server related security error. !important wouldn’t help in this case, as the server itself is blocking the images from coming through (not CSS).

    #385782

    ok,thank you.
    I’ll ask a friend who helps me a little bit with this project.maybe he figures out something.

    #386031

    Tom
    Lead Developer

    Sounds good – let me know if you get it working or not 🙂

Viewing 15 posts - 1 through 15 (of 23 total)

You must be logged in to reply to this topic.