Celebrating 7 Years! Get up to $30 off GeneratePress Premium!

[Support request] Woocommerce composite products – "Proceed to checkout" not working

Home Forums Support [Support request] Woocommerce composite products – "Proceed to checkout" not working

Home Forums Support Woocommerce composite products – "Proceed to checkout" not working

  • This topic has 21 replies, 2 voices, and was last updated 3 years ago by Steffen.
Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #554460
    Steffen

    Hi,

    already filed a support case with Somewherewarm Support for their Composite Products plugin and it looks like the problem is the GP Premium addon – “Woocommerce”.
    Problem is – once I put a “Composite” product in the cart I canhnot proceed to checkout as the “Proceed to checkout” part is completely missing. Once I deactivate the “Woocommerce” part from the GP Premium plugin this part comes back to life.

    Please let me know how to fix that issue.

    I added the link to the composite products.
    Once you add any of tose in the cart you won’t be able to checkout.

    A staging site is available btw.

    Cheers
    Steffen

    GeneratePress 2.0.2
    GP Premium 1.6.2
    #555050
    Tom
    Lead Developer
    Lead Developer

    There seems to be a 500 error happening. Can you check your error_log file on your server for any recent PHP errors?

    #555677
    Steffen

    Well I have a debug log with lots of stuff in there.

    It would be easier to give you a (secure) link to my staging site or at least the possibility to send the log via mail…
    I don’t have any clue about coding otherwise I wouldn’t ask for support.
    So please let me know how to reach you to send the log or the access details to my staging site.
    Don’t want to post stuff like this on a public forum.

    Thanks

    Cheers
    Steffen

    #555895
    Tom
    Lead Developer
    Lead Developer

    If you can include the last 10 or 20 entries in an email using our Account Issue form, that would be great: https://generatepress.com/contact/

    Be sure to mention this topic.

    Thanks!

    #559818
    Steffen

    done as mentioned…
    Tons of :
    PHP Notice: Trying to get property of non-object in ….. link-template.php

    #560220
    Tom
    Lead Developer
    Lead Developer

    Hmm I’m not seeing anything from you in our system. Can you try emailing support@generatepress.com directly?

    #560733
    Steffen

    I was getting a “processing” message after I clicked “send” in your support form.
    Just sent an email. Hopefully this can be resolved soon.

    #562296
    Steffen

    Worst support so far.

    Its unfortunately more like a question and answer pingpong from day to day.

    By the way: The Somewherewarm support who made the Composite Products plugin already disables all plugins on my staging site and found out its your GP Premium addon.
    I then futher investigated and disabled the modules in your plugin one-by-one. And viola – it was the Woocommerce module in your plugin.

    Except this issue the plugin works fine though.

    Cheers

    #562303
    Tom
    Lead Developer
    Lead Developer

    I’m sorry to hear that. Unfortunately sometimes it takes a little pingpong to find the issue.

    While I believe that the issue disappears when you disable our WooCommerce module, that isn’t the full answer.

    For example, try our demo here: http://demo.generatepress.com/shop/

    The proceed to checkout button appears and is functional, even with our WooCommerce module activated.

    That means something on your site is conflicting with our module – that conflict is what I was trying to figure out.

    I understand the frustration and the need to get issues like this resolved quickly. Unfortunately, it can take time when dealing with edge cases like this.

    #562309
    Steffen

    Ok I finally did as suggested !

    Every single plugin has been disabled EXCEPT:

    Woocommerce
    Woocommerce product bundles (bundles used in my composite products)
    Woocommerce composite products (the plugin which gives a problem with your Woocommerce module)
    GP Premium

    I even switched to the Twenty Seventeen Theme and Then to Storefront…

    nothing – “Proceed to checkout” is still not working when your Wocommerce “module” in GP Premium is running.

    I even installed a Debug plugin now and this is what I get:

    PHP Fatal error: Uncaught Exception: Invalid product. in /homepages/……/wp-content/plugins/woocommerce/includes/data-stores/class-wc-product-data-store-cpt.php:149
    Stack trace:
    #0 /homepages/……/wp-content/plugins/woocommerce/includes/class-wc-data-store.php(149): WC_Product_Data_Store_CPT->read(Object(WC_Product))
    #1 /homepages/……/wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-product.php(135): WC_Data_Store->read(Object(WC_Product))
    #2 /homepages/……/wp-content/plugins/gp-premium/woocommerce/functions/functions.php(692): WC_Product->__construct(2830)
    #3 /homepages/……/wp-includes/class-wp-hook.php(286): generatepress_wc_secondary_product_image(”)
    #4 /homepages/……/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    #5 /homepages/……/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #6 /homepages/xx/xxxxxx in /homepages/xxxxxx/wp-content/plugins/woocommerce/includes/data-stores/class-wc-product-data-store-cpt.php on line 149
    [28-Apr-2018 07:15:37 UTC] PHP Notice: Trying to get property of non-object in /homepages/……/wp-includes/link-template.php on line 317

    ……..Cheers

    #562463
    Steffen

    Some more very interesting stuff:

    I was playing around in my store to find differences with the Composite products, Bundled products and simple products.
    I recorgnized that another product was causing the same issue. This time though it was a Variable product , not a Composite product! Other variable products were working.

    There was a difference though:
    The variable product that messed up the checkout had cross-sell items linked. And guess what – linking simple cross-sell items worked fine. Once I link a variable cross-sell product to the main product the cart gets messed up again.

    So I took another look on the fatal error in the debug log – line 692 in your GP Premium functions.php file and kicked out the part with the secondary product image…..success!
    #
    Looks like something about that part doesn’t work as it should under special circumstances. I guess its your part now.

    Even though it seems to be working fine now there are still errors generated:
    PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘generatepress_wc_secondary_product_image’ not found or invalid function name in /homepages/xxxxxx/wp-includes/class-wp-hook.php on line 286
    [28-Apr-2018 15:23:43 UTC] PHP Notice: Trying to get property of non-object in /homepages/xxxxxxx/wp-includes/link-template.php on line 317

    EDIT: The last line “PHP notice:” was another plugins issue. Whats left is the PHP warning..

    #562629
    Tom
    Lead Developer
    Lead Developer

    Very interesting – thanks for debugging this!

    I’ll take a closer look at what’s going on and will update you. For now just keep the secondary image option turned off.

    Really appreciate it ๐Ÿ™‚

    #562652
    Tom
    Lead Developer
    Lead Developer

    Just trying to reproduce this on our end so we can find a fix.

    Here’s what I’ve done:

    1. Added two variable products, with multiple images.
    2. Made the two products cross sell to each other.
    2. Turned on the secondary image in the Customizer.

    When I add one of the items to the cart, the cross sell appears and so does the checkout button.

    Did I miss a step?

    Really appreciate your help ๐Ÿ™‚

    #562657
    Tom
    Lead Developer
    Lead Developer

    Since I can’t reproduce, can you try something for me?

    In gp-premium/woocommerce/functions/functions.php on line 692, replace:

    $product = new WC_Product( get_the_ID() );

    With:

    $product = wc_get_product();

    Does that fix it?

    #562668
    Steffen

    Hi Tom,

    1. Sounds fine but what exactly do you mean with multiple images ? I don’t use gallery images but the variable “sub” products each have their own image.

    2. Correct

    3. Didn’t even turn on the secondary image in the customizer so its “off”.

    …will try your suggestion asap

Viewing 15 posts - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.