[Resolved] Why does the ecommerce site template use a POSTS page as the homepage?

Home Forums Support [Resolved] Why does the ecommerce site template use a POSTS page as the homepage?

Home Forums Support Why does the ecommerce site template use a POSTS page as the homepage?

  • This topic has 7 replies, 3 voices, and was last updated 4 weeks ago by Fernando.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2282957
    Papa

    All of the research I have done says it’s fine to use the posts page as homepage for a BLOG, but you should definitely use a STATIC frontpage as your homepage for an ecommerce site.

    So why does the shop site template in the Site Library use a POSTS page?

    Should I convert it to a static page (with a plugin?, rather not)? Should I just load/import the template and build a static homepage from scratch (pain) – or choose another template (very few to choose from as it is).

    Suggestions? Or what am I missing?

    Thanks Gang!
    Papa Fig

    #2282961
    Ying
    Staff
    Customer Support

    Hi there,

    Are you talking about this SHOP template? https://gpsites.co/shop/

    If so, it is using a static page as the frontpage.

    #2283045
    Papa

    Thanks for the quick reply @Ying

    Yes. That is the one I am talking about.

    Here is the end of the url from when I am editing the page:

    wp-admin/post.php?post=3582&action=edit

    and instead of the “publish” button, it gives me the “schedule” option when I’m editing that page.

    I do see the option under the general Settings|Reading|SetFrontPage option to set the SHOP page as the “static” frontpage when I load the site (or reload a fresh install to a dummy site) – but on my main site that option is gone (this page no longer shows up under that dropdown menu), is it because I renamed it at one point?

    What’s going on?

    Should I just reload the template and start over, I’ve got “only” a few days of work building the site so far, half of that was the graphics/logos which I won’t lose.

    Thanks again for all the help. Sorry I am such a newbie to generatepress (I’m using the pro version), but I will get there.

    #2283103
    Fernando
    Customer Support

    Hi Papa,

    instead of the “publish” button, it gives me the “schedule” option when I’m editing that page.

    Do you have the Gutenberg plugin installed? Can you try deactivating it and see if this issue gets resolved? Seems to be a Gutenberg plugin issue: https://github.com/WordPress/gutenberg/issues/27251

     is it because I renamed it at one point?

    Do you mean you renamed the page name of the static shop page? If so, just select the name you set in the dropdown. It should appear there still with the new name.

    Should I just reload the template and start over, I’ve got “only” a few days of work building the site so far, half of that was the graphics/logos which I won’t lose.

    If you can’t set it back, you can provide temporary credentials through the private information field, and we’ll try to take a quick look and see if it can be reverted back.

    Hope this clarifies!

    #2283133
    Papa

    Thanks Fernando,

    You guys have a very active support going on here. It is great for customers of GeneratePress, like me.

    You saw the partial url I posted above, why does it have $post.php/posts (can’t see the txt right now, but if reference to posts in the link and has “recent articles” type section at the bottom of the original homepage for that site)?

    Do you have the Gutenberg plugin installed?

    No Gutenberg plugin.

    Do you mean you renamed the page name of the static shop page? If so, just select the name you set in the dropdown. It should appear there still with the new name.

    Yes. I think so. It should, but it doesn’t. I even tried renaming it to shop but that didn’t work either.

    If you can’t set it back, you can provide temporary credentials through the private information field, and we’ll try to take a quick look and see if it can be reverted back.

    Well… didn’t fix my issue yet, but after checking my plugins I see a couple, like WP Show Posts (does that add the “latest articles” at the bottom of the template homepage?) that I may poke around a bit more in that area.

    I currently have the following plugins installed:

    theShark (imported about 20 listing into woocommerce from my Etsy store)
    GenerateBlocks
    GP Premium
    Happyforms (free)
    MC4WP:Mailchimp for WordPress
    WooCommerce
    WP Show Posts

    That’s it. I am about to remove Happyforms and MailChimp – I think theShark plugin might have installed those, not sure. I didn’t install them myself (separately) and I’m not big on a bunch of plugins – like to keep it to the bare minimum.

    If that doesn’t work I’ll also remove theShark, probably don’t even need it installed now that I got my listings imported. I got the lifetime paid version of that plugin, so I can always reinstall if I can’t fix the issue and need to start from scratch.

    The only plugins left will be the GeneratePress ones at that point. I’ll let you know.

    Thanks,
    Papa

    #2283140
    Fernando
    Customer Support

    Yes, we try to respond to every topic as best we could to assist our customers. 🙂

    I see. The page might have been set back to draft mode.

    Can you click the date in the Status and Visibility section of the page and click and reset? Example: https://share.getcloudapp.com/Wnu767Nz

    Then, click on publish.

    Kindly let us know how it goes.

    #2283817
    Papa

    OK.

    I found the “frontpage” page, I had left it without a title. It was under PAGES|All Pages|(no title). Once I gave it a name again (I used CHOPnCUT, it’s chopncut.com) it reappeared in the SETTINGS|READING|Homepage:<drop down menu>

    It is also showing the UPDATE button when editing that page, instead of the SCHEDULE button.

    So maybe it’s all good at this point.

    Just FYI – I deactivated the plugins:
    Happyforms (free)
    MC4WP:Mailchimp for WordPress

    – I couldn’t tell that did anything so far, but I left them deactivated for now.

    Thanks for the help – You Guys are Great!
    Papa

    #2285523
    Fernando
    Customer Support

    I see. You’re welcome Papa! Glad to be of assistance!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.