Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] When blog is set to home page, shows only pages, not posts.

Home Forums Support When blog is set to home page, shows only pages, not posts.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #148727

    Is there a setting I am missing?

    In the customizer, if I set the home page to a static page, and set the homepage to home, it brings up the homepage fine and then I put the blog page in a menu, and it brings up my gridded post layout fine.

    However, if i set the home page to “blog” and well as recent posts, it brings up only pages. I also checked in my menu, the home page menu item, to make sure it was pointing to, and it still shows up as pages. No posts, just pages.

    Any idea what’s going on?



    First off, I should have prefaced my post with this…

    As long as I’ve been using GP, on over 40 sites, this is the first time I’ve had anything resembling an issue. THAT is impressive. Give yourself a well deserved pat on the back. Not many people take such pride in their work these days.

    Second, I’ve uploaded two screenshots that will hopefully show you what I am referencing:

    Blog and Blog set


    Blog and Home set

    Thanks in advance for any insight.

    Lead Developer
    Lead Developer

    Hi Mick,

    So you’re trying to set the homepage as a static page and the blog as the same page?

    I think this is probably a limitation in WordPress itself – I don’t think those two values can point to the same page.

    If you’re trying to list posts on a regular page, you may need to use a plugin like the “Display Posts Shortcode”.

    Let me know if I’m misunderstanding 🙂



    When I received your email, something clicked. I remembered I done what I wanted to do, before, on another site. I went and checked the settings, thinking at the very least I could import them to the new site. It was much more simple than that.

    Just because I’m using a page called blog as a sort of template for the blog posts, doesn’t mean I have to define my home page as a static page. Duh!

    Switched it to latest posts and it works like a charm. If it was a snake it would have bit me, comes to mind 🙂

    Thanks for getting back to me so fast, sorry I took up any of your time with this. Keep up the good work!


    Lead Developer
    Lead Developer

    Ah! Glad you got it sorted out! Glad I could somewhat help 🙂

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.