[Resolved] When activating Child Theme some elements disappear

Home Forums Support When activating Child Theme some elements disappear

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1261787
    Don

    When downloading and activating the child theme from:
    https://docs.generatepress.com/article/using-child-theme/#installing-a-child-theme

    It causes several design elements to disappear, such as the site logo, and other page elements, etc. there may be more affected, however, I immediately revert back once I notice it breaking all of the elements configured through the wordpress customizer option that your documentation says shouldn’t happen? Is there something else that needs to be setup for the child theme to work correctly? I need to add some customizations to the functions.php but right now it seems to break things.

    #1261813
    Leo
    Staff
    Customer Support

    Hi there,

    That definitely shouldn’t happen – haven’t had this reported before.

    You haven’t added anything in the child theme yet?

    Is the child theme activated currently? If not can you activate it for us to take a look?

    Thanks 🙂

    #1261848
    Don

    The child theme is active now, it also doesn’t seem to be picking up any of my additional styles I’ve added through the extra css either.

    #1261853
    Leo
    Staff
    Customer Support

    That is super strange.

    It’s a fresh child theme from our site without any modifications?

    Can you disable all plugins except GP Premium to eliminate any conflicts?

    As for CSS, are you referring to the Additional CSS field? If so that is attached to the parent theme itself so you’d want to copy from the parent theme and add it to the child theme style.css file.

    #1261869
    Don

    Once I went back and reread the documentation I noticed the part about the footer copyright and logo as well as the additional css section. Since the original Merch theme had all of this in there I assumed it would pick it up from the main theme.

    Everything is all set and working now, thank you so much for your patience.

    #1261874
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.