[Resolved] website went blank space

Home Forums Support website went blank space

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #108215
    architectureonscreen

    I wan following the instruction on fixing the navigation menu on top, after I paste the css on function.php my site went blank and I don’t know what to do… please help…

    #108223
    Tom
    Lead Developer
    Lead Developer

    Your functions.php file should only have PHP in it.

    Your style.css file is where you should add CSS.

    Adding CSS: http://generatepress.com/knowledgebase/adding-css/
    Adding PHP: http://generatepress.com/knowledgebase/adding-php-functions/

    To fix this, access your site using FTP or your hosting control panel File Manager.

    Navigate to wp-content/themes/generatepress_child and open the functions.php file.

    Remove the CSS you added, and save.

    If you’re not comfortable with doing that, try giving your hosting a call, they should be able to remove the problem code and restore your website.

    Let me know if you need more info 🙂

    #108224
    architectureonscreen

    thanks for the quick reply…I’m afraid to do that, and I really am new to this so I just started my website from scratch, I went to bluehost and install wordpress and I get to open my site but its back to default and lost all my blog input. I’m trying to remember everything to recreate my website.
    I guess I’m afraid to do more editing now, I can’t even locate “js folder”. I’ll just keep my website simple, it was really scary looking at a blank site.
    Thanks anyways!

    #108300
    Tom
    Lead Developer
    Lead Developer

    Bluehost re-installed your website instead of just removing the functions.php file?

    Adding CSS can’t crash your website, but PHP can. So you’re safe making CSS changes.

    If you’re trying to use a sticky navigation, you can start with one of our child themes (Mantle, Exhibit) and then customize from there.

    Another option is using a plugin like this: https://wordpress.org/plugins/sticky-menu-or-anything-on-scroll/

    #108432
    architectureonscreen

    the csr I talked to from bluehost said I reinstalled over it, because i reinstall wordpress and that I should have had a backup for my blogs.
    I am now using Exhibit, and it looks ok, my only concern with it is that I don’t want my logo at the center, It looks ugly in there, it has to be on left. How can i do that? I can’t seem to make it happen using Element Spacing.
    Thanks

    #108433
    architectureonscreen

    Oh I figured it out, it’s just the Layout, Header Alignment, Left.You don’t have to reply on it. Thanks!

    #108486
    Tom
    Lead Developer
    Lead Developer
Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.