[Support request] Website Running Slow

Home Forums Support Website Running Slow

This topic contains 42 replies, has 3 voices, and was last updated by  Tom 2 months ago.

Viewing 15 posts - 1 through 15 (of 43 total)
  • Author
    Posts
  • #597098

    Jo

    Hi,

    My website is running slow and my web host has said I should contact you.

    Please can you have a look at the report and advise what needs to be done?

    https://gtmetrix.com/reports/www.charnwoodbookkeeping.co.uk/2AWjykAs

    Thanks

    Jo

    GP Premium 1.6.2
    #597149

    David Customer Support

    Hi Jo,

    Have a look at the Waterfall report on the GT Metrix. The first 2 requests are waiting for access to the HTTP domain and then redirect to the HTTPS. This is taking 10 seconds, the majority of which is waiting for the host. I tested this against a European based server and got the same result.

    Every subsequent request is also experiencing a high wait time. I would take this back to the host and have them look at resolving this. Once you have done we can help you with optimizing the site. Some guidelines are provided here, but best to clear the host issue first:

    https://generatepress.com/fastest-wordpress-theme/

    Let me know

    #597203

    Jo

    Hi David,

    Thanks for the reply.

    I feel like ‘piggy in the middle’ as the host is saying it is ‘developer’ issues.

    On Friday I was getting a lot of unwanted traffic from Russia. They were adding links to comments on my blog. I contacted my host and they added an IP block code under .htaccess for all of Russia. Also on Friday I added Google Analytics. Since these changes the site has been running very slow.

    I’ve got the host to remove the block on Russia. If they start targeting my site again, the block may need to be re-instated. Unless you know of a better way to block a country??

    Does Google Analytics slow down sites?

    These are the comments from the host regarding the optimization required:

    “I have check and found that the gzip optimization is enabled also I have increase the PHP directive values
    Further I have check that waterfall and found that it is response externally when url is access from server end
    ==================
    Server
    Apache
    Keep-Alive
    timeout=10, max=100
    Date
    Mon, 11 Jun 2018 11:49:18 GMT
    Content-Encoding
    gzip
    Connection
    Keep-Alive
    Vary
    Accept-Encoding,User-Agent
    Content-Length
    20
    Cache-Control
    max-age=604800
    Content-Type
    text/html; charset=UTF-8
    ===================
    12:59 pmYou can check from the above logs

    Also from the GTmatrix I can see the below suggestion
    =====================
    Optimize images
    Defer parsing of JavaScript
    Serve resources from a consistent URL
    Make fewer HTTP requests
    ———–
    This page has 27 external Javascript scripts. Try combining them into one.

    This page has 20 external stylesheets. Try combining them into one.

    I can confirm that there is no issue on server end as your account is hosted on shared server
    and we do have any other customer asking for slow response of server
    1:08 pmAnd we have already enabled GZIP defalate modulde
    for your account
    and keep alive is already been enabled”

    Please let me know your thoughts?

    Thanks

    Jo

    #597223

    David Customer Support

    Hi Jo,

    ok lets deal with the developer side of things.
    First off aside of this image most images are fairly well optimised. The original is showing up at 1.3meg as it is 3500 pixels wide, you could just resize it to 800px for your needs:

    https://charnwoodbookkeeping.co.uk/wp/wp-content/uploads/2018/04/Profile-Pic-White-Background-Cropped.jpg

    Next lets install a plugin call Autoptimize:

    https://en-gb.wordpress.org/plugins/autoptimize/

    and use the settings provided here:

    https://generatepress.com/fastest-wordpress-theme/

    For the time being leave the Remove Query Strings from Static Resources unchecked. I would only advise activating this once you have finalised the site.

    This will consolidate the scripts, optimise your code and reduce the number of requests.

    Let’s see what improvements that make.

    For security you should look at a plugin such as wordfence – the free version will do.:

    https://en-gb.wordpress.org/plugins/wordfence/

    This article is quite thorough for helping you set this up:

    http://www.wpbeginner.com/plugins/how-to-install-and-setup-wordfence-security-in-wordpress/

    #598058

    Jo

    Hi David,

    I’ve optimzied the image as per your suggestion.

    I’ve installed Autoptimze and I think I have all the settings correct?

    I’ve checked Remove Query Strings from Static Resources as the website is finalised. Is this OK?

    The Pingdom score is very good, however the GTmetrix is poor.

    Please can you look at this and advise?

    I will install Wordfence.

    Many thanks

    Jo

    #598105

    David Customer Support

    Hi Jo,

    hmmm i can still see the Large 1.3mb image being loaded. Did you resize the image on desktop and then re-upload and add to the page again? If so can you clear your caches (Note there is one in Autoptimize) and any that are on your server.

    Sorry i missed the question regarding Google Analytics. This should have no noticeable effect to the site speed. The biggest speed drain will come from the Facebook and Twitter feeds on the site, we can look at someways to improve that but as they are out of your control it will be a case of tweaking them.

    Check out the image and let me know, in the meantime i’ll see what else could be causing a problem

    #598936

    Jo

    Hi David,

    I resized the image in wordpress. I’ve deleted the cache.

    Can you check again?

    Thanks

    Jo

    #598946

    David Customer Support

    Hi Jo, sorry i am still seeing this, i notice the name has changed but you can see the width and height hasn’t.

    <img class="alignnone size-full wp-image-613" src="https://charnwoodbookkeeping.co.uk/wp/wp-content/uploads/2018/04/Profile-Pic-White-Background-Cropped.jpg" alt="" width="3570" height="2228">

    #598958

    Jo

    Oh! I think I may know why. You are looking in charnwoodbookkeeping.co.uk/wp

    That is another copy of the site (the one I used before I launched).

    I am using https://charnwoodbookkeeping.co.uk/

    Could this be the issue?

    #598975

    David Customer Support

    Hi Jo, unfortunately not – looking at the root domain site.
    if you think the update is correct then head to Autoptimize and Purge the Cache (you can do it from the WP Admin Bar at the top of the page) and then disable Autoptimize

    #598977

    Jo

    ok – done that

    #598982

    David Customer Support

    OK – so it looks like that full size image is locked into the database. WP can be a tricky bugger sometimes. Are you able to crop the original Image (outside of WP) and then re-upload this with a completely different filename?

    Then delete out the old image in the page and apply the new one?

    #598987

    Jo

    Yes I will do that.

    Sorry for being naive, but I don’t get if I change an image size in my live site, why would that change in the /wp site? If you amend an image on one copy of the site, does it automatically amend it on the other copy?

    #598991

    Jo

    https://charnwoodbookkeeping.co.uk/wp-content/uploads/2018/04/Profile-Pic-White-Background-Cropped-e1528799960784.jpg

    This is the image I have amended. You said the name has changed, but I didn’t change the name??

    I’m very confused.

    #598992

    David Customer Support

    Hi Jo,

    i am not sure how you have the site copy set-up. If they are both using the same database then yes you could experience this. If i am working on a hosted site, then i use a Staging site (good hosts generally provide this) that way you can make changes on the staging and when happy you push them to the live site. Hope this helps.

Viewing 15 posts - 1 through 15 (of 43 total)

You must be logged in to reply to this topic.