[Resolved] Visual editor (TinyMCE) not accessible

Home Forums Support [Resolved] Visual editor (TinyMCE) not accessible

Home Forums Support Visual editor (TinyMCE) not accessible

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #675274
    Esben

    When I am trying to click on the visual editor (built in tinymce) nothing happens. I am using Sections as well.

    Chrome console says:
    wp-tinymce.php:1 Failed to load resource: the server responded with a status of 403 (Forbidden)
    wp-tinymce.php:1 Failed to load resource: the server responded with a status of 403 (Forbidden)
    post.php?post=6&action=edit:2704 Uncaught ReferenceError: tinymce is not defined
    at post.php?post=6&action=edit:2704
    wp-langs-en.js?ver=4800-20180716:235 Uncaught ReferenceError: tinyMCE is not defined
    at wp-langs-en.js?ver=4800-20180716:235
    at wp-langs-en.js?ver=4800-20180716:519
    post.php?post=6&action=edit:2699 Uncaught ReferenceError: tinymce is not defined
    at Object.load_ext (post.php?post=6&action=edit:2699)
    at post.php?post=6&action=edit:2709

    GeneratePress 2.1.4
    #675342
    David
    Staff
    Customer Support

    Hi there,

    first test is apply #1 here:
    https://docs.generatepress.com/article/debugging-tips/

    If that doesn’t work then you need to contact your host and get them to check the permissions are correct.

    #675982
    Esben

    Thanks David,

    The problem is still present even after deactivating all non GP plugins.

    Tried all the things in the debugging article. The problem still persists.

    What is it that I should ask my host?

    #676000
    Esben

    After trying a number of solutions found via Google, this guy helped me: https://wordpress.org/support/topic/tinymce-is-not-defined-tools-not-appearing/

    Turns out I had a .htaccess file in my wp-includes folder (it is only supposed to be present in the root). I deleted it and know it all works.

    #676109
    David
    Staff
    Customer Support

    Great to hear you got it resolved. And thank you for sharing the solution

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.