[Resolved] Video block in some browsers devices don’t show first frame + fonts not loading

Home Forums Support Video block in some browsers devices don’t show first frame + fonts not loading

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1349887
    Ricardo

    Hi,

    I’m wondering if you could give me some help on these topics. I don’t know how to solve those.

    1)

    I am using video block on these pages:

    https://wordpress-262052-1321013.cloudwaysapps.com/

    https://wordpress-262052-1321013.cloudwaysapps.com/concerto-fado-porto/

    I have no poster image and set preload to “metadata”.

    On the desktop browsers everything is ok.

    On chrome mobile version also ok.

    But on firefox mobile, it shows a dark background without image. On safari (in an iphone 8) it shows a transparent background.

    I think that one solution would be to set a poster image.

    But if there was a way to force to load the first frame on all devices and browsers, it would be fantastic.

    Mmostly because the effect of having the video paused on the first frame it’s better then having a picture that it’s hard to get exactly as a the first frame on the different devices.

    2)

    In the customization/typography I set up hedings to be open sans.

    But on this pages

    https://wordpress-262052-1321013.cloudwaysapps.com/

    https://wordpress-262052-1321013.cloudwaysapps.com/concerto-fado-porto/

    I set it up to be archivo black via generateblocks/advanced typography.

    On the desktop browsers everything is ok. But on all mobile browsers that I’ve tested (chrome, safari on iphone and firefox) the headings aren’t archivo black. Although if I resize desktop browsers all headings are archivo black.

    I also tried to use css, but the result was the same.

    What can I do to solve this?

    Thanks in advance,
    Ricardo Pons

    #1349922
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    1. I’m afraid I’m not sure if there’s a solution here, but I’m no expert when it comes to the video block.

    2. I’m not seeing a request to Google for the Archivo font in the HTML. Have you toggled the “Google font” option in the GenerateBlocks settings?

    #1349948
    Ricardo

    Hi,

    Regarding video blocks, I’ll stick with the poster.

    I didn’t toggled “google font”, but changed that right now and nothing changed.

    What I don’t understand is that it is ok for desktop browsers. Also if I add css for those specific pages that doesn’t make changes also.

    I have not any cache.

    If you want I can give access to those pages.

    #1350514
    David
    Staff
    Customer Support

    Hi there,

    it doesn’t look like Archivo Black is loading on any device.

    Edit the Typography and delete the font name and paste in this Archivo Black

    #1350537
    Ricardo

    Hi,

    It’s loading fine on desktop here.

    http://somup.com/cYie20QE4o

    Did that change, but still the same problem.

    The issue, I think, is that the settings on customizing/typography take control on the mobile devices.

    I also tried to add via on page css, but the issue is the same.

    #1351065
    Tom
    Lead Developer
    Lead Developer

    It looks like you’re using lower case characters, which is resulting in a 404 on the Google server.

    Instead of: archivo black

    Do this: Archivo Black

    #1351090
    Ricardo

    Hi,

    David has already told me that but I just tested in one headind and it didn’t changed anything.

    But now I’ve changed all the headings and it’s ok.

    Thank you!!

    #1351849
    Tom
    Lead Developer
    Lead Developer
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.