Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Using Page Header on Blog, but {{page_title}} blank

Home Forums Support Using Page Header on Blog, but {{page_title}} blank

  • This topic has 3 replies, 2 voices, and was last updated 3 years ago by Leo.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #421938
    Samuel

    Here is my issue:

    I have a page set as my posts page (i.e. posts are not the home page).
    I have a page header assigned in global locations to the posts page.
    That page header uses {{post_title}}

    When I load the posts page, it loads the correct page header, but it does not pull the title of the posts page. The title is completely blank. When I use that page header with any other page, it works fine. This seems to be a bug.

    GP Premium 1.5.2
    #421957
    Leo
    Staff
    Customer Support

    Hi there,

    It’s actually not a bug – generally page titles are only displayed for static page and not the main blog page.

    I would recommend creating a separate page header with everything the same and just add Blog as the page header content.

    #421966
    Samuel

    I would suggest maybe changing this in a future version because it seems to make sense to use the page title in this case as well. Thank you for the answer!

    #421967
    Leo
    Staff
    Customer Support

    Thanks for the suggestion 🙂

    I think you are the third person bringing this up so far. If we get more feedback on this we’ll definitely consider it!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.