[Support request] Use infinite scroll problems

Home Forums Support Use infinite scroll problems

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1177033
    Nikolay Stoyanov

    Hi,

    When I’m using Use infinite scroll on start display 1st few post correctly from the exact category, once when I click on load more post button (Use infinite scroll) is start to display post from other categories and also did not show all post from that category (in that category there more than 50).

    When I did not use Use infinite scroll (using normal pagination previews 1 2 3 ….50 next) all categories show correctly from each category and did not mix few category in one place.

    Any idea what can cause this?

    Regards: Nick

    #1177741
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can link us to the site in question?

    You can edit the original topic and use the private URL field.

    Let me know 🙂

    #1177899
    Nikolay Stoyanov

    I did it, but at the moment the web site did not use “Use infinite scroll” as it is not display correctly.

    Regards: Nick

    #1177910
    Leo
    Staff
    Customer Support

    Can you activate it so we can actually see the issue?

    It’s tough to tell without seeing it as we haven’t had any other reports on this.

    Thanks!

    #1177924
    Nikolay Stoyanov

    Ok.. it is activated now. I can hold like this only few hours, then need to back again as it is Official Municipality web site.

    Thank you!

    #1177926
    Nikolay Stoyanov

    Hope page is working fine, because I only allow post from only one category there.

    You need to check category /?cat=10

    1st load all is ok only post from that category, 2nd load is again ok, but after 3rd load is start to show post from /?cat=11…

    Same is with other category.

    Thanks

    #1178066
    Leo
    Staff
    Customer Support

    Sorry I’m a little bit confused about what the problem is.

    So basically, the posts are showing up in the wrong category when infinite scroll is activated?

    If so, we would need to go through some plugin conflicts debugging steps, unfortunately.

    Are you able to set up a staging site and clone the current set up so you can disable all plugins and any custom functions except GP Premium?

    We haven’t had this issue reported before so the step is necessary.

    #1178157
    Nikolay Stoyanov

    Hi again.

    I did disable all other plugins except GP Premium and the problem is still exist.

    1st load is perfect, 2nd load is again perfect, 3rd load start to mix the category post and then the button load more disappear.

    The php code of theme is 100% original and it is not touched from me.

    For now I will use the theme with disable option “Use infinite scroll”. I did some changes on CSS nav and now looks good to me.

    Thank you for your time anyway.

    Regards: Nick

    #1178815
    Tom
    Lead Developer
    Lead Developer

    When you activate infinite scroll, what happens if you manually type /page/2, /page/3 etc.. into the browser bar? Are the correct posts shown?

    #1178859
    Nikolay Stoyanov

    Hi,
    When I activate infinite scroll and type manually in address bar /?cat=10&/page/2 it load 1st page perfect, 2nd page perfect as before, 3rd page is load again post from page 1, 4rd page is load again post from page 2 and so on… but post which are display in the query are all only from one this category (ID=10) without mixing post from other category. But this category 10 has more than 60 post… I only see 1st 20, as my WordPress display 10 post per page.
    Regards: Nick

    #1179176
    Tom
    Lead Developer
    Lead Developer

    Where is the ?cat=10 parameter coming from?

    Our infinite scroll feature simply grabs the link URLs from your pagination that appears when infinite scroll is turned off, and loads the posts from that page.

    If the URL in the pagination isn’t pulling in the right posts, our script won’t work. If the URLs are correct, the script will work.

    #1179341
    Nikolay Stoyanov

    The parameter ?cat=10 coming from page archive with which I have problem when I use infinite scroll ->
    http://websiteurl/?cat=10.

    I did the test with manually add page/2 after the parameter cat=10.

    Infinite scroll works perfect on home page, but the problems appear when I browse category post.

    Let me know what I’m miss.

    Regards: Nick

    #1179854
    Tom
    Lead Developer
    Lead Developer

    Is there any way you can throw up a staging site so we can keep infinite scroll activated without affecting your live website? I need to see the actual issue to get a better idea of what’s going on.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.