Black Friday Sale! Get up to $30 off GP Premium! Learn more ➝

Home Forums Support uploading error

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #211567
    Kathy

    I have a site on my local machine I did using generatepress. Works beautifully. However, when I upload it to a new host and try to test it I get the following message:

    Fatal error: Call to undefined function generate_body_schema() in /home/tlewallen/public_html/wp-content/themes/generatepress-child/header.php on line 19

    I am not a code person and cannot figure out how to fix this. Any help would be much appreciated.

    Thanks.

    #211568
    Tom
    Lead Developer
    Lead Developer

    So it looks like your child theme is calling for a GeneratePress core function which doesn’t seem to exist.

    This most likely means you don’t have the parent theme installed/updated: https://generatepress.com/install-generatepress/

    Let me know πŸ™‚

    #211768
    Kathy

    Thanks so much. I tried that and it still did not recognize the parent theme. However, I saw in another one of your posts that you could change css by adding the simple css plug in. So since my page was just one page I just recreated it and added my new css that way. πŸ™‚

    New problem though. Since I only have one page I don’t have a nav menu. When I look at the page on a mobile device I still get the black bar with the burger button. Is there any way to get rid of that?

    #211773
    Kathy

    Never mind! Just saw the ‘no navigation option in the customizer. Thanks for all you do!

    #211808
    Tom
    Lead Developer
    Lead Developer

    Glad you got it sorted πŸ™‚

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.