Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Updates don't show as available for site running old version of GPP

Home Forums Support Updates don't show as available for site running old version of GPP

  • This topic has 3 replies, 3 voices, and was last updated 3 years ago by Leo.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #428485
    NBC

    I’m way behind on doing anything with this site, but I leave it up in the hopes that I’ll get back to it. Meanwhile, it’s running WP 4.9, GP 1.4, and GPP 1.2.67, but no updates show as available for GPP.

    In the GeneratePress section of Appearance, I don’t see the box into which to type or paste the registration authorization code. Am I stuck in a loop in which I can’t update because I’m not shown as authorized, and I can’t authorize because I can’t update?

    Not sure what’s going on here, but I’d like to fix it. Thanks for any applicable help!

    [Edited to fix typographical error]

    GeneratePress 1.4
    #428563
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That’s a very old version – you’ll likely have to manually update to the latest version: https://docs.generatepress.com/article/updating-gp-premium/#manually-updating

    Once you’re updated to the latest, you’ll be able to input your license key.

    Let me know if you need more info 🙂

    #428730
    NBC

    Well, I managed to figure it out enough that I was able to get it working.

    Tried deactivating GPP and replacing it with the new version. I would have had to delete the old and add the new, which (according to the dialog box that came up) would have deleted all of GPP’s data. Oops. Nope.

    Tried downloading the GPP ZIP archive, uploading it to the plug-ins folder, deleting the old GPP version folder, and unZIPping the new version there, as I would do under localhost. My FTP client wouldn’t unarchive the ZIP file.

    Finally, I went back into the plug-ins page, added the ZIP archive, and reactivated it, then went back in via FTP and deleted the ZIP file that didn’t get unarchived.

    At least this way I didn’t lose my settings.

    I was able to reauth GPP and all seems to be well.

    I do note that sometimes, GPP doesn’t seem to “know” that updates are available, even on sites running most-recent versions.

    #428890
    Leo
    Staff
    Customer Support

    Hi there,

    Keep in mind that the update needs to be activated in order to receive notification: https://docs.generatepress.com/article/updating-gp-premium/#activating-updates

    And if the site’s URL changed, you will need to re-do the process above again.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.