[Support request] Update Generatepress version 1.11.2 .and Yoast plugin Broken my website

Home Forums Support Update Generatepress version 1.11.2 .and Yoast plugin Broken my website

  • This topic has 3 replies, 2 voices, and was last updated 1 month ago by Leo.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1401279
    Carlos

    Hello there,

    I update my Generatepress theme to new version 1.11.2 today, after all ok.

    Select the option for Yoast to analyze my content to suggest a link to my post. After this my server broken! my website with blank pages and in loading ….

    When I deactivate the Yoast plugin, everything returns to normal.

    It seems that there is an incompatibility between Yoast plugin and the new version of Generatepress.

    Any idea please?

    #1401290
    Leo
    Staff
    Customer Support

    Hi there,

    Can you check the error_log file on your server? It should tell you what’s causing the error.

    #1401359
    Carlos

    Leo,

    In the file error_log I only can see:

    785373 2020] [proxy_fcgi:error] [pid 17186:tid 140494227048192] [client 189.103.234.231:0] AH01067: Failed to read FastCGI header - see https://serverpilot.io/community/articles/error-failed-to-read-fastcgi-header.html for more information, referer: https://www.devocionalescristianos.org/wp-admin/post.php?post=5135&action=edit

    The article from serverpilot say that maybe a plugin. In the file php7.2.slow.log only can see references to the prelaoding from Wp Rocket Plugin, I don’t know:

    [13-Aug-2020 13:07:21]  [pool devowordpress] pid 26847
    script_filename = /srv/users/serverpilot/apps/devowordpress/public/wp-admin/admin-ajax.php
    [0x00007fe7aae1ca80] curl_exec() /srv/users/serverpilot/apps/devowordpress/public/wp-includes/Requests/Transport/cURL.php:162
    [0x00007fe7aae1c9c0] request() /srv/users/serverpilot/apps/devowordpress/public/wp-includes/class-requests.php:381
    [0x00007fe7aae1c8c0] request() /srv/users/serverpilot/apps/devowordpress/public/wp-includes/class-http.php:394
    [0x00007fe7aae1c730] request() /srv/users/serverpilot/apps/devowordpress/public/wp-includes/class-http.php:626
    [0x00007fe7aae1c690] get() /srv/users/serverpilot/apps/devowordpress/public/wp-includes/http.php:162
    [0x00007fe7aae1c600] wp_remote_get() /srv/users/serverpilot/apps/devowordpress/public/wp-content/plugins/wp-rocket/inc/Engine/Preload/AbstractProcess.php:202
    [0x00007fe7aae1c560] preload() /srv/users/serverpilot/apps/devowordpress/public/wp-content/plugins/wp-rocket/inc/Engine/Preload/AbstractProcess.php:159
    [0x00007fe7aae1c4d0] maybe_preload() /srv/users/serverpilot/apps/devowordpress/public/wp-content/plugins/wp-rocket/inc/Engine/Preload/FullProcess.php:44
    [0x00007fe7aae1c430] task() /srv/users/serverpilot/apps/devowordpress/public/wp-content/plugins/wp-rocket/vendor/wp-media/background-processing/wp-background-process.php:315
    [0x00007fe7aae1c380] handle() /srv/users/serverpilot/apps/devowordpress/public/wp-content/plugins/wp-rocket/vendor/wp-media/background-processing/wp-background-process.php:175
    [0x00007fe7aae1c310] maybe_handle() /srv/users/serverpilot/apps/devowordpress/public/wp-includes/class-wp-hook.php:287
    [0x00007fe7aae1c230] apply_filters() /srv/users/serverpilot/apps/devowordpress/public/wp-includes/class-wp-hook.php:311
    [0x00007fe7aae1c1c0] do_action() /srv/users/serverpilot/apps/devowordpress/public/wp-includes/plugin.php:478
    [0x00007fe7aae1c0e0] do_action() /srv/users/serverpilot/apps/devowordpress/public/wp-admin/admin-ajax.php:191

    Any idea Leo?

    Thank you very much!

    #1401363
    Leo
    Staff
    Customer Support

    I really don’t think GP is the issue – we are running Yoast on this site and didn’t experience this.

    Can you activate Yoast again and keep all other plugins disabled?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.