[Resolved] Unable to update GeneratePress (due to inconsistent file permissions?)

Home Forums Support [Resolved] Unable to update GeneratePress (due to inconsistent file permissions?)

Home Forums Support Unable to update GeneratePress (due to inconsistent file permissions?)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #223942
    Rens

    I’m getting an error when trying to update GeneratePress to the latest version:

    Er is een fout opgetreden bij het bijwerken van GeneratePress: De update kon niet worden geïnstalleerd omdat we sommige bestanden niet konden kopiëren. Dit komt meestal door inconsistente bestandsrechten. woocommerce.php, languages, js/superfish.js, js/hoverIntent.js, js/superfish.min.js, js/customcontrol.slider.js, css/superfish.css, languages/sk_SK.mo, languages/generatepress.pot, languages/zh_TW.po, languages/it_IT.po, languages/generatepress.mo, languages/bg_BG.po, languages/fr_FR.mo, languages/ru_RU.po, languages/nb_NO.mo, languages/zh_TW.mo, languages/ru_RU.mo, languages/nl_NL.mo, languages/pl_PL.mo, languages/es_ES.mo, languages/bg_BG.mo, languages/readme.txt, languages/sk_SK.po, languages/da_DK.po, languages/el.po, languages/de_DE.po, languages/ro_RO.po, languages/it_IT.mo, languages/de_DE.mo, languages/cs_CZ.mo, languages/nl_NL.po, languages/cs_CZ.po, languages/el.mo, languages/fi.mo, languages/pt_BR.mo, languages/ro_RO.mo, languages/es_ES.po, languages/pl_PL.po, languages/da_DK.mo, languages/pt_BR.po, languages/fi.po, languages/nb_NO.po, languages/fr_FR.po.

    Translated: An error has occurred while updating GeneratePress: The update couldn’t be installed because some files couldn’t be copied. This is usually due to inconsistent file permissions. woocommerce.php, …

    I’m guessing this is a general problem with my WordPress installation, but perhaps you could give me some directions on how to solve this for GeneratePress – eg. which permissions should I set if this is indeed the problem?

    Rens

    #223967
    Ramesh Srinivasan

    Hi Rens,

    What’s the current Permission levels for the Themes\GeneratePress folder and subfolders ? Try CHMOD 755.

    Changing File Permissions « WordPress Codex

    #223971
    Ramesh Srinivasan

    And for GP Premium, the directory paths (to set CHMOD 755) are:

    wp-content/plugins/gp-premium/

    If 755 doesn’t work, you may try 775, update GP and then revert it back to 755 for extra security.

    See also: Updating Add-ons – GeneratePress

    #223985
    Tom
    Lead Developer
    Lead Developer

    If you’re uncomfortable doing the above for any reason, just contact your hosting and ask them to fix it so WordPress can write/change stuff on the server 🙂

    #224286
    Rens

    Directories where already set to 755, files to 644. It appears that some directories were owned by a different user, changing the wordpress directory and all subdirectories to www-data:www-data solved the problem. So this did the trick, for future reference:

    sudo find wordpress -type d -exec chmod 755 {} \;
    sudo find wordpress -type f -exec chmod 644 {} \;
    sudo chown -R www-data:www-data wordpress
    #224343
    Tom
    Lead Developer
    Lead Developer

    Awesome, thanks for posting the solution 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.