[Support request] Trying to display Recent Posts with a featured image

Home Forums Support [Support request] Trying to display Recent Posts with a featured image

Home Forums Support Trying to display Recent Posts with a featured image

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2036545
    Luke

    Hello,

    I’m trying to display my recent posts on the front of my blog with the title as headline with a featured image.

    Instead it’s showing the full post.

    I have read up on this, and tried using the “Recent Posts Widget Extended” Plugin, along with the “WP Show Posts” plugin.

    Neither of them have solved the problem.

    Any feedback would be great, thanks!

    #2036558
    Elvin
    Staff
    Customer Support

    Hi Luke,

    You can edit WP Show Posts to only display post thumbnail and post title by disabling the rest of the contents on WPSP’s settings page.

    On WPSP setting’s content tab, you can set the Content type dropdown to “None” instead of “full” or “excerpt”.
    https://share.getcloudapp.com/5zu9EDwN

    On WPSP setting’s meta tab, you can uncheck ALL items so none of them displays on the frontend.

    A wise man once said:
    "Have you cleared your cache?"

    #2036589
    Luke

    Okay thank you!

    Now I’m having another issue where the post is simply displaying as a link, without a header/excerpt/feature image

    Here’s the screenshot:

    https://ibb.co/ws1Dv3z

    Any idea why it’s showing my post like this?

    #2036606
    Elvin
    Staff
    Customer Support

    That’s what the effect of setting WPSP’s content type to display “None”. It removes the excerpt.

    Apologies for not being clear enough but I thought you were trying to only the list display the title and the thumbnail only.

    As for the missing featured image, make sure “Images” check box is checked on WPSP setting’s Images tab. It the post still doesn’t display an image, it’s likely because the post itself doesn’t have a featured image assigned to it yet. ๐Ÿ™‚

    Let’s clarify a few things.

    Were you trying to add a “Recent posts” list after the content on a single post page? Or perhaps, were you trying to create an archive page of “Recent posts” with WPSP?

    Let us know.

    A wise man once said:
    "Have you cleared your cache?"

    #2036609
    Luke

    No worries! It’s likely my communication as well…

    All I want is my home page to show my recent posts, with a heading title, featured image, and excerpt.

    Seems I may have done something weird, because I have a page called “New Content” with a block added that shows my recent posts.

    And even when I remove that, and default to “Show recent posts” on my wordpress homepage, it still shows the entire article instead of what I want above.

    I really appreciate the help, hope this clarifies my issue lol. I’ve only used WP themes that automatically make recent posts have a feature image/title/excerpt which is why this has been weird.

    And to confirm, I have a featured image assigned to the post. It’s showing at the top of the article.

    #2036615
    Luke

    Disregard this message above, it seems when I went into the post settings… And changed the post format to “Standard” fixed everything.

    Very weird haha.

    I should be able to head into WPSP and fix up a few final things.

    Thanks Elvin!

    #2036624
    Elvin
    Staff
    Customer Support

    No problem. Let us know if you need further help with this.

    Note: WPSP has it’s own support forum.
    Pro users – https://wpshowposts.com/support/area/pro-support/
    WP.org Support – https://wordpress.org/support/plugin/wp-show-posts/

    You can search around its forum site if you have any questions that may already be answered there. ๐Ÿ˜€

    A wise man once said:
    "Have you cleared your cache?"

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.