[Resolved] Transparent header for all pages

Home Forums Support Transparent header for all pages

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #358960
    Petr

    Hi,

    on some pages I’m using transparent header as shown here: https://docs.generatepress.com/article/merging-header-navigation-content/, but I’d like to have it set globally for the whole site.

    Is there an ellegant way, how to do it? Setting it separatelly page by page is a bit unconvenient, especially when I would decided to change something lately.

    I have no problem using a child theme or hook to do it.

    Thanks

    GeneratePress 1.3.48
    GP Premium 1.3.1
    #359150
    Leo
    Staff
    Customer Support

    Hi there,

    The new page header addon can do just that 🙂

    Check it out here: https://vimeo.com/223381628

    In should be released soon but if you are very welcome to test it out:
    https://docs.generatepress.com/article/beta-testing/

    #362305
    Petr

    Thanks a lot, that worked excellently. The new header addon is exactly, what I needed.

    Only 2 minor imperfections:

    1. After GP update, no header template was imported and former on-page header settings stayed unchanged (and the new header template selectbox wasn’t there). I had to remove the settings and save the post again. After this tweak old metabox was replaced by the new selectbox and everything worked fine.

    2. I use Elementor for page editing and with merged menu header and hidden page header I couldn’t access Elementor’s controls for the first section (they were overlapped by the merged GP header). Ehm, even I myself cannot clearly understand what I’ve written right now 😉 The point is, that I have the transparent menu, and no page header, so the Elementor content starts right on the top of the page. And there sits the merged GP header on the top of it.

    To make it short, this piece of CSS made the first Elementor section accessible again:

    .elementor-editor-active .page-header-content {
        pointer-events: none;
    }
    
    #362325
    Leo
    Staff
    Customer Support

    Thanks for reporting back!

    #1 is intended. Only the setting in blog page header in customizer is migrated over to the new page header area. This is to avoid user confusion if they are already using the meta box previously.

    #2 I believe that’s a known Elementor issue. Lyle provided a CSS solution as well: https://generatepress.com/forums/topic/cant-reach-the-section-and-paragraph-buttons-on-an-elementor-section/#post-305133

    #366748
    Annie

    Thanks for the workaround:

    .elementor-editor-active .page-header-content {
        pointer-events: none;
    }

    Works great for now, was kind of frustrating, had to uncheck the “header over content” every time I needed to change the upper Elementor section.

    #366750
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.