Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Top Bar Padding Not Working

Home Forums Support Top Bar Padding Not Working

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #458590


    i recently noticed that for unknown reason, the Top bar is much taller then my Primary Navigation Bar.

    Although their padding values are both set the same:

    TOP = '0' | RIGHT = '0' | BOTTOM = '0'| LEFT = '0'

    when i’m in the customizing theme mode (“Appearance > Customize”) And changing the values of the Top Bar Padding, for example: from ’10’ back again to ‘0’.
    I actually seeing the top bar get taller and then get smaller, to the same size as the Primary Navigation Bar.

    But when i press Published and go back to the site, the Top bar is still much taller then my Primary Navigation Bar.

    I first thought that maybe it’s because the website cache,
    But even after clearing the cache (via the WPFC plugin), the problem remains.

    Is this a known issue/bug with GP v2.0.1?

    GeneratePress 2.0.1
    Lead Developer
    Lead Developer

    Hi there,

    I’m not noticing any issues:

    The code looks ok as well. Are you seeing something different?


    Hey Tom,

    Yes, i’ve upload a screenshot for you to see:

    The Right Image, is from the customizing theme Mode

    The Left Image, is from the browser

    Can you noticed, that the banner got taller in the Left image?
    Or that the White square of Choosing Different Languages option, isn’t cut in the bottom of the Top Bar? (Left Image)

    Customer Support

    This is what I am seeing:

    and I’m not noticing any issues either.

    So it’s working correctly in the customizer mode but not on live browser?

    Have you tried clearing your browser cache?

    If it’s not working, can you turn off your caching plugin so I can see the source of the code?



    Hey Leo,

    Can’t you noticed that even in the image that you attached,
    The Top Bar is much more Taller then the Primary Navigation Bar?

    And regarding your question,the answer is yes.
    It’s working correctly in the customizer mode but not on live browser.

    I’ve already cleared cache in the website and also in my browser.

    I’ve disabled the WPFC plugin as you requested.

    Waiting for your update,

    Customer Support

    It’s hard to tell something is wrong from screenshot.

    Looks like you’ve added this CSS:

    .inside-top-bar {
        padding: 6px;

    Thanks Leo,

    That’s was a problem 🙂

    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.