[Support request] Top bar not working

Home Forums Support [Support request] Top bar not working

Home Forums Support Top bar not working

  • This topic has 9 replies, 3 voices, and was last updated 2 months ago by Fernando.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #2241232
    Sagar

    Hi team,

    This top bar I created using https://www.youtube.com/watch?v=1VQECQxeyQE&t=166s
    https://prnt.sc/4kL6ScNFIQsC (showing when logged in)

    https://prnt.sc/sn1HVSZ_WFNu (not showing in incognito mode)

    I have cleared the cache also. Please help.

    #2241271
    David
    Staff
    Customer Support

    Hi there,

    can you share a link to the site ?

    #2241281
    Sagar

    sure, 9to5job.in

    #2241300
    David
    Staff
    Customer Support

    What happens if you go to Dashboard > GenerateBlocks > Setting and set the Dynamic CSS to inline ?

    #2241656
    Sagar

    Yes, I tried. Still not working.
    Even the same settings are here on thebabycart.in , it is working perfectly.

    #2241664
    David
    Staff
    Customer Support

    Do you have any cache plugins installed ? And if so, are there separate caches for logged in and logged out users ?

    #2241730
    Sagar

    I’m using WP-Rocket on both websites. No there are no separate caches.

    #2241942
    Fernando
    Customer Support

    Hi Sagar,

    Can you try temporarily disabling WP Rocket? I believe the issue stems from WP Rocket. If you try https://9to5job.in/?nowprocket (doing so accesses the website with no wp rocket), you’ll see the Top bar appear properly.

    See: https://share.getcloudapp.com/o0uGkY8R

    A setting in WP rocket may be causing this.

    Hope this clarifies!

    #2241962
    Sagar

    Yes right, but both the websites are created equally. 100% wp rocket and other settings are the same on both websites. Then why is this issue on 9to5job but not on thebabycart?

    #2242009
    Fernando
    Customer Support

    Settings like remove unused CSS, Combine CSS, or improper use of Critical CSS are some settings that may cause issues like this.

    The way WP Rockets implements this may be different for each site. It may work seamlessly for some and cause issues for some. It would be best to reach out to WP Rocket for clarification with regards to its implementation.

    As is, it seems that WP Rocket removed CSS used for the section in question.

    You can try disabling each setting of WP Rocket one by one and see how it goes and to determine which specific setting is causing this.

    Hope this clarifies!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.