[Support request] the response is not a valid json response when saving widget

Home Forums Support [Support request] the response is not a valid json response when saving widget

Home Forums Support the response is not a valid json response when saving widget

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #1974213

    Good morning,

    When I make an adjustment in the sidebar / widget I get the message: the response is not a valid json response. I’ve already disabled all plugins, but it doesn’t work.

    Customer Support

    Hi there,

    that error generally means that there was a problem communicating the change with the server.

    First thing to check is that the WordPress URL and Site URL are matching and correct in Settings > General.
    Then check in Tools > Site Health to make sure there are no ‘errors’ warnings related to the Rest API.

    If all good, then try rebuilding your permalinks by going to Settings > Permalinks and click Save Changes.

    If the issue persists then next step is to remove any widgets / blocks you have in the sidebar. If that resolves the issue then one of those widgets may have included some invalid code.



    I’am having the same issue with the sidebar widgets.

    Things I have done already:
    – Checked the WordPress URL and Site URL
    – Check Site Health > All Good
    – Rebuild Permalinks

    I see Inactive widgets and wanted to delete these to see if this resolves the issue. But everytime I remove a Block and hit the Update button I get the error “There was an error. The response is not a valid JSON response.”. So I can not remove any widgets/blocks that I have in the sidebar.

    I’am to remove all widget’s if there is an other way to do this.

    Thanks in advance

    Kind Regards,

    Customer Support

    Hi there,

    simplest solution may be to disable the Block Widgets so you can remove the offending widget.
    This article provides the PHP Snippet to do that:


    You can always remove the snippet after clearing our the widgets if you want to use the Block Widgets


    Hi David,
    Thank you for your fast respons and your great suggestion.

    So I added to code into the snippet plugin and this converted the Widgets area to the regular non-blocks view.
    There I remove all widgets (Inactive and active).

    Then I deactivated the snippet code again.

    I added a simple Headline block to Footer Widget 2, then clicked “Update”

    Again got the error message


    When first going to “Appearance > Customize” and then “Widgets”, I there can add new block items without any issue.

    When I go to “Appearance > Widgets” and try to add another paragraph block to the content I created via above, then the error appears.


    So mean while I have been trying to add the block back into the Widgets through “Appearance > Customize” and then “Widgets”.
    But that realy is a nightmare.

    Customer Support

    silly question – if you go to Appearance > Widgets, in the Top Bar there is the List View button ( 3 line menu icon ) – can you open that and make sure there are no kinda hidden blocks in there, such as an empty container or group.


    There are no silly questions, it’s only silly if you don’t ask


    Hi David,

    I did check if there were any other item under other Widget Area’s, there were non.

    I removed the stuff I added back in today and checked the List View button, the Widget Area’s are all empty.
    Tried to add something here but got the error again.

    I also disabled all blockediting plugins like GetWid, GenerateBlocks (Sorry) and some CSS widget color plugin.
    Same result

    Installed “Health Check & Troubleshooting” plugin, which disables all Plugin’s and switched to a default theme for my session.
    Still same issue. (So it’s not a Generate Press issue)

    Reinstalled the 5.8.2 update.
    Issue still exists.


    So true

    did you manage to resolve this issue?

    Customer Support

    Natalie, if you want to create a new topic, and provide us a temporary admin login we can take a closer look to see whats going on.


    Sorry for the late response.

    I just gave up on this issue.
    I ended up makeing a footer with an Element.
    Thanks for your help.

    Customer Support

    Glad to hear you found a solution!

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.