[Resolved] Text cursors in main nav (instead of arrow)

Home Forums Support [Resolved] Text cursors in main nav (instead of arrow)

Home Forums Support Text cursors in main nav (instead of arrow)

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #518012
    George

    It’s a very minor annoyance, but an annoyance nonetheless: the cursor displays as a text cursor on hovering over items in the main nav. See https://livingwisdomschool.org/. When you move the cursor below the line of links, it behaves normally, turns into an arrow. Is there a quick fix?

    GeneratePress 2.0.2
    #518251
    Leo
    Staff
    Customer Support
    #519769
    George

    Thank you for the suggested fix. Nothing that I’ve tried so far will cure this behavior. E.g., I tried disabling all add-ons, etc.

    I also tried some CSS, like this (and variations):

    #nav .navigation li a[href=”#”]:hover {
    cursor: default !important;
    }

    Alas, a text cursor still displays instead of a pointer when hovering over main nav items that have drop-down menus. The cursor is a pointer when hovering over menu items that don’t have drop-down lists.

    #519808
    dasigna

    sorry for chiming in …

    … maybe due to the fact, that all main menue items (except for ‘contact’ and ‘home’) arent really links (they have none) and the text is recognized on hover as what it is: plain text. so you have the text cursor instead of the hand.

    maybe put an ‘#’ into the link field in wp menue settings to fix this?

    #519822
    George

    Holy smokes, that fixed it. Many thanks. For those with the same problem, here are the detailed steps:

    1. In WordPress, go to Appearance > Menus

    2. In Menu Structure, click the name of a navbar item that has a drop-down list.

    3. In the URL box, type #.

    4. Repeat for other navbar items that have drop-down lists.

    5. Save the menu.

    #519896
    Leo
    Staff
    Customer Support
    #519902
    dasigna

    my pleasure 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.