[Resolved] style.min.css not being included in preview in GP Premium Version 1.11.1

Home Forums Support style.min.css not being included in preview in GP Premium Version 1.11.1

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1392191
    Brian Jackson

    Hey Tom,

    Was testing the new GP Premium version 1.11.1 update and the new external CSS file.
    It doesn’t seem to be including the style.min.css when you are in a preview in the editor. This basically makes all the previews lose their styles.

    I did a quick test and just dropped /wp-content/uploads/generatepress/style.min.css into the header of my test site and then the preview worked fine.

    But if you compare a blog post with what is loaded in the editor during a preview you’ll see this file is for some reason missing.

    Happy to provide any other information if you need it. I was able to replicate this on a couple of sites.

    Thanks

    #1392215
    Tom
    Lead Developer
    Lead Developer

    Hey Brian,

    The CSS should load inline when previewing a page or a post. I did this to prevent caching issues/having to rebuild the file when previewing. Is it not being added inline for you?

    #1392258
    Brian Jackson

    Hey Tom,
    That’s what I thought but it doesn’t seem to be happening. My test site is at Kinsta, I disabled every plugin except for the latest GP Premium and still the same issue. I’ve cleared the entire site cache, disabled CDN, etc. The site is running on latest WP version.

    I don’t see the extra GP CSS spitting out inline.

    #1393119
    Tom
    Lead Developer
    Lead Developer

    Thanks for the heads up! Have this fixed in 1.11.2 which I’ll release on Monday 🙂

    #1393520
    Brian Jackson

    Awesome thanks Tom! Glad you were able to replicate it.

    Keep up the great work.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.