Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Struggling with backgrounds

Home Forums Support Struggling with backgrounds

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #395751
    Thomas

    Hi there,

    I am completely new in WordPress and I have no experience in CSS or HTML whatsoever.

    I am using Elementor for creating my pages, and have the following problem for my website (www.kindercoachpapendrecht.nl):

    I am trying to add a background image to my homepage, which must be a different background than the other pages. When I use the Elemetor template from my page, everything is perfect, except that I lose my header. When I use the standard template, my header is back but my background disappeared. The background somehow vanishes behind the elementor – parts. Because when I change the padding – setting (as you can see on the website now) the background image starts showing. Can someone tell me how I can somehow change the background image so it shows on my page?

    GP Premium 1.4.3
    #395909
    Leo
    Staff
    Customer Support

    Hi there,

    Not quite sure what you mean? If you are using Elementor for the content then you should use Elementor to insert a background image as well?

    Can you show me when the header disappear? Make sure you are not using Elementor Canvas as it strips all of GP’s element so header disappearing is actually normal.

    #396358
    Thomas

    Hi Leo,

    Thanks for your reaction.

    When I insert the background image in Elementor, using a standard template, the image is not showing (as you can see now in http://www.kindercoachpapendrecht.nl). I now changed the padding settings, so you can see the selected background behind the page (the sort of pink border around the content). The white and grey sections on the homepage, are supposed to be transparant with the image as the background.

    When I change the template to Elementor Canvas, i know that the header disappeares, but somehow the background image is then suddenly visible.

    What I want is that the grey areas on the homepages slides over the background image.

    Is this more clear? Hope you can help!

    Greetings!

    #396495
    Heiko

    Hi!

    Could it be, that you set your content-width to “full width”? You should insert the content of your page in a container. There is one setting in Elementor settings and one in GeneratePress to modify. You could also set the background of Elementor’s column to grey and not to the whole section, because the section covers your entire page, if you set it to “full width”.

    Heiko

    #396524
    Thomas

    Hi Heiko,

    Thanks a lot for your help! Problem’s solved!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.