[Resolved] Sticky navigation is not really sticky

Home Forums Support [Resolved] Sticky navigation is not really sticky

Home Forums Support Sticky navigation is not really sticky

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1136352
    Artem

    Hi,
    I activated sticky navigation on my site. The option ” Hide when scrolling down” is deselected.
    Nevertheless, when I scroll down my navigation disappears.
    How can I have the real sticky navigation (present all the time)?
    Thank you.

    #1136454
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can disable all plugins except GP Premium to eliminate conflicts from other plugins first?

    Let me know πŸ™‚

    #1136730
    Artem

    I did it. It’s still not sticky.
    Thank you

    #1137213
    Leo
    Staff
    Customer Support

    Can you disable all plugins and let me have a look?

    Please also disable site ground optimizer if you can.

    Thanks πŸ™‚

    #1137252
    Artem

    Done.
    Only GP Premium is active now.
    I don’t think that its a plugin, because I had the same situation from the very beginning when I started developing this site offline. It was always like this.
    Thanks.

    #1137267
    Leo
    Staff
    Customer Support

    Are you using a child theme with any sort of specific template?

    I’m seeing these classes which aren’t default GP classes:
    https://www.screencast.com/t/i2VMPlDJ

    Can you disable all your custom functions and CSS as well?

    Sorry but we need to go through these debugging steps to pinpoint the problem. We haven’t had this issue reported by others so I’m guessing it’s something specific to your set up.

    Let me know πŸ™‚

    #1137485
    Artem

    Leo,
    Thanks a lot. I tried disabling my additional CSS and it works.
    I’m not using a child theme. I put all my CSS in Additional CSS field.
    Actually, the cause of the problem was this:

    html, body {
         height: 100%;
     }

    So, I deleted it and everything works fine now. Probably, it was in conflict with some GP internal settings.
    Thanks again.

    #1138122
    Leo
    Staff
    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.