[Resolved] static home page

Home Forums Support static home page

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #81213
    Nafari Vanaski

    All I want on my home page is the site title, logo photo and menu. How can I make that happen? I’d like the rest of the pages on the site to just have the title and menu at the top.

    #81236
    Tom
    Lead Developer
    Lead Developer

    You don’t want any content on your homepage?

    So your homepage would have: Site title, logo and navigation
    Other pages would have: Site title and navigation (no logo)?

    #81237
    Nafari Vanaski

    That’s right. I like the image, but it’s really big, so I’d like it to just be on the home page. Is that possible?

    #81362
    Tom
    Lead Developer
    Lead Developer

    Have you looked at our Page Header add-on?

    It allows you to keep the site title/tagline in the header, and the include an image/content/slideshow on a per-page basis.

    If you’re wanting to use the header/logo upload, you can try this CSS:

    .site-logo {
          display: none;
    }
    
    .home .site-logo {
          display: block;
    }
    #81406
    Nafari Vanaski

    Thanks! But I’m kinda new at this — where do I add this code? I’ve created a child theme already — so would I copy the header code to the child theme stylesheet directly and then add this CSS, or would it work to just add the CSS to the stylesheet?

    #81408
    Nafari Vanaski

    What does ‘cheating ‘uh’ mean? I thought this was a free theme — am I supposed to be paying you or something? No offense meant. I’m gonna just pick another theme, ‘k?

    #81458
    Tom
    Lead Developer
    Lead Developer

    CSS can go in your child theme’s style.css file, or in a plugin like the one in my signature below.

    “Cheating ‘uh” is a WordPress permission error – nothing to do with GP.

    To fix, go into “Settings > General” and make sure your home URL and site URL match. Even if they do, click Save Settings.

    #81503
    Nafari Vanaski

    Oh, OK! I was worried — I thought there was some Big Brother stuff going on. 🙂 Sorry. Like I said, very new! Thank you for your help!

    #81507
    Nafari Vanaski

    I got that “cheatin’ uh” thing right after I sent the question about the child theme — it was just the weirdest timing. I just feel stupid about all of this. Thanks again.

    #81510
    Tom
    Lead Developer
    Lead Developer

    No worries! It’s definitely one of the more weird WordPress errors 🙂

    #98750
    john

    Hi Tom

    any idea how to fix the cheatin uh error in multisite? I get it when i try to save the copyright in the generatepress copyright add-on

    thanks!

    John

    #98751
    Tom
    Lead Developer
    Lead Developer

    Such a weird WP error.

    In my experience it’s caused by your site url and home url in “Settings – General” being different.

    Take a look and make sure they’re identical 🙂

    #98754
    john

    Hi Tom

    thanks but those fields dont show up in multisite that’s why i thought i would check with you if you know how to solve is MS?

    oh i did look int he database, and the site and home fields are the same there.

    Thanks!
    John

    #98755
    john

    NM i solved it. it started happening after adding the automatic domain changer plugin, I deactivated that and all good, just coincidence that i also enable the copyright addon near the same time, sorry to waste your time.

    #98756
    Tom
    Lead Developer
    Lead Developer
Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.