Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Static Home Page has no header or top menu

Home Forums Support Static Home Page has no header or top menu

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #413023
    Irene

    Hello,
    Any page that I select as Static Home page is displayed without it’s header and top nav. If I turn the page back to not being the Static Home – the header and top nav are there. This can be repeated using any page on the site. The only change is whether that page is designated as Static Home.

    So, I’m thinking it’s not any setting in the individual pages – but how the system is handling the Static Home designation. How do I tell it not to strip the header and top nav when a page is designated as Static Home?

    Thanks!

    GP Premium 1.4.3
    #413123
    Leo
    Staff
    Customer Support

    Hi there,

    You have this CSS added:

    .home .inside-header.grid-container.grid-parent {
        display: none;
    }
    #413372
    Irene

    Hi Leo,
    Thanks for your response, but I’m not sure what to do with what you said. I have not manually edited the CSS. And, this issue appears on any/all pages that get designated as Static Home. As soon as the page is no longer designated as Static Home – it no longer has the issue of failing to show header and top nav. So, I’m not sure if CSS on any particular page is the cause.

    It seems to me that there should be something in the overall settings provided in the nice GUI of GP Premium that I would tick to say DO NOT HIDE header and top nav just because page is serving as static home.

    Could you tell me more about how to address this.
    Thanks

    #413377
    Leo
    Staff
    Customer Support

    Yes because the CSS is targeting the home page, hence .home.

    Check Customizer > Additional CSS.

    You should see the code at top titled /* Hide header on Home page */.

    Remove the code should solve the problem. This is not something GP’s setting can do.

    #414350
    Irene

    Here’s the exact steps I used (based on what you shared with me). It worked. Thanks!

    In the WP dashboard,
    1. Go to Appearance>Customize
    2. In the left menu select Additional CSS
    3. Find and remove exactly this comment and code

    ————————–
    /* Hide header on Home page */

    .home .inside-header.grid-container.grid-parent {
    display: none;
    }
    ———————

    4. Click the blue Save button at top of left menu

    #414356
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.