[Resolved] Speed / Impressions Drop-off

Home Forums Support Speed / Impressions Drop-off

  • This topic has 5 replies, 3 voices, and was last updated 3 months ago by David.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1263585
    Michael

    Hello guys,

    I hope you are all well. I noticed today that our impressions have nosedived in GSC significantly. I have been spending the best part of the day trying to work out why.

    There are no manual actions against us. I’ve investigated our backlinks and they seem to be the same as before, so it’s not that either. I checked the speed (experimental) report and it tells me that there are errors with the mobile speed and warnings with the desktop speed. I thought it might be a glitch because up until now the speed for both has been good, so I wanted to validate but there is a message telling me “task validation is temporarily disabled due to upcoming changes in the report”.

    Instead I ran one of the flagged pages within Page Speed Insights to see if I could find out more information there:

    https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Freclaimdesign.org%2Fvases-reclaimed-wood-stands&tab=mobile&hl=en_GB

    The mobile score is 90, and desktop is 96. However the errors in GSC talk about FID issue and FCP issue.

    One of the main issues seems to be server response times:

    https://www.dropbox.com/s/omlmlxd5215qidu/ttfb-screenshot.jpg?dl=0

    It mentions this could be themes might contribute, so I wanted to ask if you had any ideas. I’m at a total loss as to what is going on, or how to go about fixing. It’s also weird because the pages flagged have not changed at all in months, and previously were getting good page speed results.

    Thank you for your help.

    Michael.

    #1263955
    Leo
    Staff
    Customer Support

    Hi there,

    I really don’t think the theme is the cause here.

    The error indicated that themes, plugins, and server specifications all contribute to server response time so that’s pretty broad.

    You’d need to start by disabling all plugins to narrow down the issue.

    #1264559
    Michael

    Hi Leo,

    I’ve run this test that was suggested in Google Webmaster forum and it is for some reason highlighting the theme code – I really have no idea what is going on, but maybe this might make more sense to you:

    https://aw-snap.info/file-viewer

    https://www.dropbox.com/s/inxngnim6gic9ic/aw-snap1.jpg?dl=0

    https://www.dropbox.com/s/ca3pztom37f1z2j/aw-snap2.jpg?dl=0

    Appreciate your help. Ultra demoralizing putting 4 months work in to build the site up to see it start tanking in a couple of days only for reasons unknown.

    Michael.

    #1264999
    David
    Staff
    Customer Support

    Hi there,

    aw-snap.info seems to be not liking the <noscript> tags that are being added by your lazy loader. But it looks like a false negative ie.

    Note: Links inside noscript tags can be problematic because they are hidden from most users. You want to make sure they are all legitmate links, no spam.

    On inspection of your site i cannot see that issue. It just looks like that tool is missing the earlier closing </noscript> tags…

    You can of course disable the lazyloader to test if the error passes….

    Pagespeed insights does not have enough real world data to give a true result. I checked your Home and example page above and the performance is great. So i don’t think that can be the issue behind a drop off in impressions.

    #1265068
    Michael

    Thank you David – back to the drawing board for me in that case

    #1266036
    David
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.