[Resolved] Solved: Live preview in customizer partly broken / Nginx

Home Forums Support [Resolved] Solved: Live preview in customizer partly broken / Nginx

Home Forums Support Solved: Live preview in customizer partly broken / Nginx

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #555139
    Jaakko Pöntinen

    Hello.

    This is actually a post about a solution that worked for me. I trashed a client’s previous base theme/builder because of reasons unfortold.

    Got GP on, brought everything back up – boom, good ol’ customizer broken, live preview mostly not working.

    The Webserver runs Nginx, so I poked around and finally, decided that it could be a server-side cache thing. So I downloaded Nginx Helper and force-purged all cache. This is not recommended if you have a huge network of sites with a gazzillion things cached – but for me, it was perfect.

    And you know what? Customizer live preview got fixed. I’d never have believed it. I’ve had broken customizers before and have just been stumped. The great interweb also has veeeery little information on how to solve these problems. Luckily, I got the clues needed to solve the problem.

    Wee!

    Cheers all.

    Jaakko Pöntinen / Mainio Mooses sp.
    WordPress / WooCommerce development

    GP Premium 1.6.2
    #555338
    Tom
    Lead Developer
    Lead Developer

    Glad you got it working! The Customizer can be excluded from any server caching in your nginx.conf file I believe 🙂

    Thanks for sharing!

    #555580
    Jaakko Pöntinen

    Hey,

    Thanks for the tip, I’m gonna remember that! :O

    – JP

    Jaakko Pöntinen / Mainio Mooses sp.
    WordPress / WooCommerce development

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.