[Support request] Smooth scrolling position of the links

Home Forums Support Smooth scrolling position of the links

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1505342
    Rolandas

    I use sticky navigation.
    The smooth scrolling feature does not jump to the page top (About 50 – 60 px remains at the top)
    Maybe some correction is possible with css.

    #1505380
    Elvin
    Staff
    Customer Support

    Hi,

    Can you provide us any screen recording of this?

    I’m not sure I’m seeing what you mean on my end as shown here:
    https://share.getcloudapp.com/OAuJ26lP

    A wise man once said:
    "Have you cleared your cache?"

    #1505905
    Rolandas

    I meant not what you recorded in the video.
    I tried to use the smooth-scroll class for a few headings (I would use it for all).
    In the previous post, I indicated which ones.
    Scroll to the anchor text not landing in the right spot, on the top of the page, leaving a space of about 50 – 60px.
    Please watch the video:
    headers with links anchors and with a smooth-scroll class do not rise to the top of the page.
    The last headers in video are without a smooth-scroll class, ant they rise to the top of the page.
    How do you make headers with a smooth-scroll class rise to the top of the page?

    #1506048
    David
    Staff
    Customer Support

    Hi there,

    the issue is because of the sticky navigation. GP offsets the height of the sticky navigation when smooth-scroll is enabled. There isn’t currently an option to filter the offset.

    You could disable the GP smooth scroll, and use a plugin like this:

    https://en-ca.wordpress.org/plugins/easy-smooth-scroll-links/

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.