[Support request] Smooth scroll not really smooth

Home Forums Support [Support request] Smooth scroll not really smooth

Home Forums Support Smooth scroll not really smooth

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #575482
    Norman

    Hi team GP,

    I’m sorry to bother for the second time today. My smooth scroll is not that smooth is it? Did I do something wrong?

    GP Premium 1.6.2
    #575642
    David
    Staff
    Customer Support

    Hi Norman, have you activated the smooth scroll in the customiser? Its under General. And the Klik Hier button has a class of smooth, this should be smooth-scroll

    #575976
    Norman

    Hi David,

    I used this to do the smooth-scroll: https://gist.github.com/generatepress/60b9235b43866e346320e11cf40bb054

    I deleted that code and did what you said, but it is still not smooth. It jumps to the target area.

    #575984
    David
    Staff
    Customer Support

    Hi Norman, yes smooth-scroll is now built in so no need for the additional code. Just make sure it is active in the customiser. And you need to change your button class from smooth to smooth-scroll

    #576770
    Anass

    Me too I observe that the effect is not applied when the option is marked. Is there any way to solve this? Thanks.

    #576845
    Norman

    Hi David,

    I changed that class, but it doesn’t make a difference.

    #576952
    David
    Staff
    Customer Support

    Hi Norman, possibly a plugin conflict, can you try disabling other plugins to see if there is a clash? I would start with the header position highlight bar you are using.

    Let me know

    #576962
    Norman

    Except for these plugins, I deactivated all of them, and it still didn’t work.

    GP premium
    Gridable
    Simple CSS
    Updraft
    WPML

    #576967
    David
    Staff
    Customer Support

    Hi Norman,

    could be a bug with the sticky navigation, can you disable this for me please and remove the reading bar as well.

    #576970
    Norman

    I have both disabled

    #576991
    David
    Staff
    Customer Support

    Hi Norman, ok sorry this is taking so long. I can see the #start ID on the button. Where is the anchor link for this to jump to? Personally i would use the GeneratePress Section ID as my jump link.

    #577027
    Norman

    It’s no problem, I’m glad you can help.

    I placed this anchor in the page header

    <a name="start"></a>

    So the smooth scroll would go down the page to the first section.

    I’ve changed the # to the section ID, bit it seems not to make a difference..

    Edit: to clarify, it scrolls to the right place, but it jumps instead of smooth scrolling

    #577035
    David
    Staff
    Customer Support

    Hi Norman, now if it is this, then i will kick myself and laugh a lot. The a href you have got has a comma in the classes like so:

    <a class="smooth-scroll, button2 green" href="#homekeuze"><b>Klik hier</b></a>

    remove that comma so:

    <a class="smooth-scroll button2 green" href="#homekeuze"><b>Klik hier</b></a>

    #577131
    Norman

    Hi David,

    I’m afraid you have to kick yourself, because it works now 😀

    It’s unbelievable how such a small thing can make a difference.

    Thanks a lot for finding it out!

    #577138
    David
    Staff
    Customer Support

    Ha ha, Norman thank you for your patience, i think i went code blind…… note to self on this one. Glad it’s working!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.