[Resolved] Smooth Scroll

Home Forums Support [Resolved] Smooth Scroll

Home Forums Support Smooth Scroll

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2197641
    Rob

    HI I have searched for an answer but can not find a solution.

    I have added an anchor link to my top too buttons and added the smooth scroll php snippet to my fucntions Child theme

    add_filter( ‘generate_smooth_scroll_elements’, function( $elements ) {
    $elements[] = ‘a[href*=”#”]’;

    return $elements;
    } );

    I stll can not get it to work

    wowcreativemedia.co.uk

    #2197655
    David
    Staff
    Customer Support

    Hi there,

    have you enabled Smooth Scroll in Customizer > General?

    #2197657
    Rob

    Thats what i was missing! Thank you all working now

    #2197669
    David
    Staff
    Customer Support
    #2221034
    Melvin

    Hi David,

    I managed to get the smooth scroll function working by adding the smooth-scroll class to the hyperlink. Somehow this effect only works on desktops and tablets, but not on mobile. Did I miss out on anything?

    #2221079
    David
    Staff
    Customer Support

    Hi there,

    make sure to clear any browser caches on your device, then retest the smooth scroll link.
    If that still doesn’t work then raise a new topic and provide a link to yours site and we’ll take a look.

    #2221092
    Melvin

    Hi David,

    After clearing the mobile browser cache, it still didn’t work. I’ll start a new topic.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.