Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Small issue with the footer widgets

Home Forums Support Small issue with the footer widgets

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #50842
    Merry Makowski

    Hi guys, no idea why, but in spite of marking 0 widgets and saving that repeatedly,
    http://prntscr.com/5cp46b

    all of them show up.

    Do you know what I can be doing wrong to get such results?

    Thank you, Merry

    #50844
    Merry Makowski

    Here is the page I am working with and all the footer widgets:
    http://sfiandtripleclicks.com/

    #50845
    Merry Makowski

    I have a Jetpack installed there and it has separate Widget settings. I tried with those settings unable and disable and I still was not able to make those widgets invisible.

    #50860
    Tom
    Lead Developer
    Lead Developer

    Hi Merry,

    Is that a page or post you’re trying to disable the widgets on?

    When you choose 0 and save, does that option stick, or move back to default?

    You can turn the widgets off globally in the Customizer, but I’m curious as to why you aren’t able to turn it off within the post/page – you certainly should be able to.

    Let me know 🙂

    #51050
    Merry Makowski

    Hi Tom, thanks so much for caring and being here for us.

    This is a page and when I clicked on save, it stayed on zero.

    Today I got read of the footer widgets completely,
    but the only option for it, was to change the global footer settings to zero in your addons layout settings. So I can’t have one page with widgets and another without, it seems like your addons overite the regular footer widget choices on the side of page edit.

    Interesingly, with side widgets is diffrent, in your addons I have chosen “content – sidebar”, and in the page sidebar layout, I’ve chosen “content – no sidebar”, and it works.

    Tom, if you need my login to look at this strange widget behavior yourself, I more than gladly provide that for you. If you opened my page, are the colors ok or too greenish…

    #51055
    Tom
    Lead Developer
    Lead Developer

    Definitely something strange happening on your site – can’t reproduce it on my end. The metabox on the page itself has priority over the Customize option.

    If you’d like you can send me a temp admin login to support@generatepress.com and I can take a look around 🙂

    #51704
    Tom S

    Hi Tom

    I have the same issue. The footer widgets are disabled when set to zero on my blog page, but reappear when I set “Set Front Page – Posts Page” to the blog page I have created for posts. It appears that this is where the override is occurring.

    Cheers

    Tom S

    #51901
    Tom
    Lead Developer
    Lead Developer

    Hi Tom,

    By default, WordPress ignores any and all metabox entries if the page is set to the display posts.

    Recently, I discovered a way to remedy this when using Page Headers, so I’ll be looking to apply the same solution to the other options.

    For now, if you’d like to hide the footer widgets on the blog, you can use this CSS:

    .blog .footer-widgets {
          display: none;
    }

    Let me know if you have any other questions 🙂

    #101658
    Mark Hannon

    I was also forced to use the “nuclear” option and hide the footer widgets on all but the front page with CSS on my child theme. I had set the global options to no footer widgets with the intent to show 4 on the home page only. Only problem was that every time I went to make the change on the home page, after updating, the original settings remained. I tried several times and every time was the same.

    I finally set the global settings to 4 footer widgets for all and added this to my header:

    if ( is_front_page() ) {
    		echo "<style type=\"text/css\">.footer-widgets{display:none}</style>";
    }

    Don’t know if this is a plugin or a theme issue but until it’s resolved, feel free to use my solution.

    #101659
    Mark Hannon

    URL for the above post by the way: http://www.americandrystripping.com/

    #101683
    Tom
    Lead Developer
    Lead Developer

    Here’s a pure CSS version:

    .footer-widgets {
          display: none;
    }
    
    .home .footer-widgets {
          display: block;
    }

    When 1.2.9.6 is released, you’ll be able to do this: http://generatepress.com/forums/topic/placeholders-for-hidden-footer-widgets-showing/#post-101409

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.