[Resolved] Placeholders for Hidden Footer Widgets Showing

Home Forums Support [Resolved] Placeholders for Hidden Footer Widgets Showing

Home Forums Support Placeholders for Hidden Footer Widgets Showing

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #101307

    I have two footer widgets on display: one to show related posts and another to show a loop of a custom post type. I want the related posts displayed on single post pages only and that shows correctly. The related posts is from a plugin that has an option to display on single post pages only. The problem is with the second footer widget. I want it to show on the home page only and it does. However, on the single post pages, it shows the footer widget placeholder with the text, “Replace this widget content by going to….”

    I have tried various widget control plugins like Widget Logic, Widget Wrangler, and Dynamic Widgets to no avail.

    I have not changed themes like the other poster on this forum with a similar situation.

    Any suggestions on how I can prevent the widget placeholder from showing in pages where it was not supposed to?

    Lead Developer
    Lead Developer

    Hi there,

    In, you’ll be able to set the footer widgets using a function similar to the sidebar layout currently.

    For now, try this..

    1. Set it up so you’re only showing 1 footer widget in “Appearance > Customize > Layout”. This will be the global setting throughout your site, and will make sure the related posts widget is the only widget showing up on single posts.

    2. Is your homepage static? If so, edit the page, and set the Footer Widgets metabox to display 2 widget areas on this page only – this way, only this page will display both widget areas.

    Let me know if that works for you or not 🙂


    Hi Tom,

    I followed your first recommendation and set the global setting to only show 1 footer widget. This worked and made the footer widget placeholder disappear.

    Unfortunately, I am not using a static page for my home page so recommendation #2 won’t apply.

    I was able to make a temporary workaround by adding the second widget on Footer Widget 1. Coupled with the Dynamic Widgets plugin, the second widget only shows on the home page. Still needs formatting to show the posts on multiple columns but it will have to do for now.

    Thanks for the tip and I look forward to your next update so I can really make my site look the way I want it to!

    Lead Developer
    Lead Developer

    Thanks! The filter will be available in ( is already being reviewed/about to be released). Should only be about a week and bit until the next version.

    Once is available, you’ll be able to do this: https://gist.github.com/generatepress/6094d2d4401fecacf143

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.