[Resolved] Slow page loading

Home Forums Support Slow page loading

This topic contains 17 replies, has 2 voices, and was last updated by  David 3 weeks, 3 days ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #1142681

    Richard

    Hi,
    My web page loading speeds are mediocre on desktop and poor on mobile according to Pagespeed and confirmed by use. I am using your Bold skin.

    I have removed all plugins that are not directly needed for the theme and I have reduced all images to the bare minimum but now struggling to improve further.

    Are you able to give any guidance please?

    Thanks
    Richard

    #1142693

    David Customer Support

    Hi there,

    first off try the Optimization tips for Autoptimize provided here:

    https://generatepress.com/fastest-wordpress-theme/

    Secondly check your background images / background overlay images in Elementor – some of there are being requested from HTTP instead of HTTPs, which creates a redirect. Simply remove the image and then re-add them … it should update the URL to HTTPS.

    #1142698

    Richard

    Hi David,

    Thank you for your quick response.I will look at the Autoptimize now however I thought I should let you know that as part of getting my image size all images, including background overlay have been removed and re-added earlier today. Do you have any further thoughts on that aspect? Also can you tell which ones are requesting from http?

    Thanks
    Richard

    #1142721

    David Customer Support

    I just added a GT Metrix report in the Site URL field ( in first original topic ). If you check the Pagespeed tab > Minimize redirects you’ll see the images being served over HTTP.

    You may need to update the URLs on your site – plugins like this help:

    https://en-gb.wordpress.org/plugins/velvet-blues-update-urls/

    #1142729

    Richard

    Thanks David, I’ll take a look now,

    I added Autoptimize and ythat has made an improvement – still not in the green for either desktop or mobile yet.

    I noticed that the default settings for “Exclude CSS from Autoptimise” are different to those in the recommended settings – they are wp-content/cache/, wp-content/uploads/, admin-bar.min.css, dashicons.min.css

    Should I replace these default setting with your recommended ones, add them to the end of this list or ignore the recommending settings in favour of the defaults?

    Thanks
    Richard

    #1142746

    Richard

    Hi David,

    From last reply I’m sorry but I’m struggling to understand what you mean by:

    “I just added a GT Metrix report in the Site URL field ( in first original topic ). If you check the Pagespeed tab > Minimize redirects”

    I’m not an expert on Pagespeed, I’ve only just come across it…

    Thanks
    Richard

    #1142754

    David Customer Support

    Unless its a very specific need i leave the Autoptimize CSS Exclusions as the Default.

    In your original topic: ie. https://generatepress.com/forums/topic/slow-page-loading/#post-1142681

    Click the Users Website link to see the GT Metrix Report

    #1142771

    Richard

    I’m sorry but I am still not getting this – I can’t for the life of me see a Users Website Link.

    I have clicked on the link in the post which takes me back to my initial post … but I don’t see it

    #1142776

    Richard

    So I have run Velvet Blues with all options ticked except GUID updating, http://<my url> to https://<my url> this gave the following:

    Success! Your URLs have been updated.

    Results
    94 Content Items (Posts, Pages, Custom Post Types, Revisions)
    0 Excerpts
    0 Links
    68 Attachments
    1 Custom Fields

    Unfortunately, no change in PageSpeed scores.
    Still not been able to find the Users Website link – I know it’ll be so obvious when I find it 🙂

    #1142828

    David Customer Support

    Maybe you can’t see the link …. which would be odd.
    Go to:
    https://gtmetrix.com

    Sign Up for a free account, which will allow you to change the test server to the UK ( under Analyze Options ) and then run a test on your site.

    It’ll provide a lot greater detail then the just the Pagespeed test.

    On the Waterfall tab you’ll see the biggest issues is the Waiting Time of the first request – which is something you will need to speak with your host about.

    #1142836

    Richard

    Hi David,

    Thanks. I went directly to the gtmetrix site and ran a test there (just using the Canada server). I can see that despite running Velvet Blues the redirects (http > https) to my images are still happening.

    It is odd because all of those images are ones I have loaded today and the site has been running https for some time now. Any mote thoughts on that?

    I suspected my server is a bit slow – I do have an upgrade option but I would prefer to get my site reasonably optimised with all the obvious stuff resolved first before taking that route.

    Should I be using CDN image caching?

    Thanks
    Richard

    #1142845

    David Customer Support

    You’ll probably need to update those background images again as they are added using CSS which Velvet Blues won’t update. But by re-adding them should fix it.

    The autoptimize is generally enough for most sites aside of keeping things to a minimum.

    CDN is good if you’re targeting visitors that are not in the same country as your Servers. If thats not the case then its pretty pointless.

    #1142866

    Richard

    Hi David,

    I have removed and re-added but it still adds with http rather than https. There doesn’t appear to be a way to edit the permalink for the image.

    You mention its added by CSS, do I need to make a change to that – where does it pick the information from to use http rather than https?

    Thanks
    Richard

    #1142873

    David Customer Support

    The CSS is generated by Elementor – so you cannot edit it.
    If you go to Media Library and select one of those images – check the URL it provides. If it still says HTTP: then delete the image and re-upload it with a different filename ( WP doesn’t like images with the same name ) … then re-add that to the Elementor background overlay.

    #1142879

    Richard

    Thanks

    I’ve just found that the permalinks for my pages also begin with http rather than https. Does this suggest I have an overall setting that is incorrect somewhere?

    To see this I have gone into Pages-><my page> and then the settings block on the right hand side

    Cheers
    Richard

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.