Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Site shows as Undefined on iPhone and iPad

Home Forums Support Site shows as Undefined on iPhone and iPad

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #176195
    Terri Horsmann

    Hi Tom-
    First, thanks so much for creating GeneragePress. I’m a GP Premium user and love the theme – it was exactly what I was looking for.

    I have two questions:

    1) on iPhone and iPad devices (only) my site immediately shows a popup in Safari that indicates my site is undefined. Specifically, the full popup message says, “http://www.terrihorsmann.com undefined” There is an option to select ‘ok’ and when doing so, the page will load. This happens on every page of the site, making it necessary to hit ‘ok’ to load each page, and sometimes they seem to then be quite slow.

    So you have some background:

    — Clearing Safari’s History and Website data doesn’t solve the issue, nor rebooting devices, etc.

    — I’ve seen the posts by other GP users about ‘fatal undefined’ errors, but I’m not getting anything like that. No other error messages about strings…just the whole site as undefined.

    — Jetpack – I tried deactivating (even though I didn’t have it set up, just activated) but that did not fix the issue.

    — Wondered if it could be because I have my site Title and Description set to not display, but that seems odd. The site name, etc. is in the index code.

    — I’ve looked at the error log through my ISP, but it doesn’t show any errors.

    — I don’t have an SSL as it doesn’t seem necessary for the static content on my site. But wondered if it’s an SSL or certificate error.

    — *** I have not yet deactivated all plug ins (although I only have those activated I’m using) and activated them one at a time to troubleshoot, because this issue has been present since I bought GP Premium and started designing the site – in other words, before I had downloaded most of the other plug ins.

    I’ve tried to solve this myself by looking high and low for answers through the GP Support and Knowledgebase, WordPress forums, other help sites; tried to use wp_debug, used Inspect Element in Firefox….all to no avail. With _debug and Inspect Element I’m not knowledgeable enough to know exactly what I should be looking for or how to make corrections without causing other errors.

    2) re: tablets — a few pages are displaying incorrectly in different layouts on tablets only. The content is getting pushed over to the right side of the page (Title of page, then big blank space on left, and main content pushed to right. I’m not using sidebars). This wasn’t happening just days ago, so I must’ve changed something, but can’t figure out what it is.

    — Oddly, the pages are displaying incorrectly in Landscape on iPad, and Portrait on a Droid/Galaxy only — but display correctly in the reverse directions on each respective device. If that’s not crazy making! 🙂

    — I’ve used the SiteOrigin Editor on these pages (without containers) and wonder if that’s part of the issue, but don’t know how to solve it.

    These are few of the pages it’s happening on:
    http://www.terrihorsmann.com/testimonials/
    http://www.terrihorsmann.com/background/
    http://www.terrihorsmann.com/journeytomediumship/
    http://www.terrihorsmann.com/contact/

    Yet, these pages are ok:
    http://www.terrihorsmann.com/readings/
    http://www.terrihorsmann.com/blog/
    and the Home page

    I am so hopeful you can help with these issues. Especially the Apple device error that my site is ‘undefined.’ I’ve reached my last nerve on trying to research and solve both of these questions myself, so appreciate ANY insights and help you can offer!

    Thanks so much!

    #176202
    Terri Horsmann

    Re: my prior post — I’m sorry, I pasted several URLs from my site to point you to the pages that aren’t displaying correctly (on tablets) and didn’t include formatting, yet the list of URLs aren’t showing in this Support post.???
    I’ll try the names of the pages instead at http://www.terrihorsmann.com :
    Terri’s Background, Journey Into Mediumship, Testimonials, and Contact.

    Thank you!

    #176204
    Tom
    Lead Developer
    Lead Developer

    Hi Terri,

    1. This is very strange. Can you try updating to the latest version of GP Premium?: https://generatepress.com/knowledgebase/updating-add-ons/#manual-update

    2. I think this is because you’re using panel cells to center the testimonials on the page.

    Can you remove the cell you created to add the space on the left, and set the other cell to 100% width and let me know? I should be able to give you some CSS to achieve the same look 🙂

    #176482
    Terri Horsmann

    Hi Tom-
    Thanks so much for your fast reply – I really appreciate it! First chance I’ve had today to see your message.

    1) I’ll be happy to try the manual reinstall/update. But, I do need your help for logging in to the GP site (this feels almost like asking you how to turn on my computer 🙂 But I don’t know that I had set up an account. I have no record of it and when I’ve tried my various log ins it doesn’t work. Have also tried my email address (the same one I used for the purchase) to reset password (and several possible user names) but it shows it’s not on record so I can’t get to a reset page. Was also just looking on your site to see where I can register/login for first time, but am just not seeing it…what am I missing here that has got to be obvious??? (also tried my WP login for the heck of it..)

    2) Also very willing to try your suggested solution and see if it works. One thing, though, did you have a chance to look at the other pages I mentioned with the same display error? Just wondering if you think it’s the same issue as they are laid out a bit differently.

    Thanks again!

    #176489
    Terri Horsmann

    Hi Tom-
    Second message tonight with update:

    Re: 2) Thanks to your suggestion I got the display to work. You were right it was the panel on the left (I had three cells/columns). I changed all layouts to two cells/columns and that did the trick. Works on all devices again, in all orientations. Thanks so much for catching the problem!

    Re: 1) still the same status, when I hear from you about how I can log in to GP site, then I can try the manual update (I always update the theme through WP).

    Thanks!

    #176518
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Can you email me at support@generatepress.com with the email you purchased with? I’ll set up an account for you 🙂

    #176637
    Terri Horsmann

    Hi Tom-

    Just sent you the email. Thanks! 🙂

    #176732
    T H

    Hi Tom-

    You answered both my questions and everything is resolved.

    re: 1) the ‘Undefined’ pop up: After you helped me get my GP account set up and I was logged in, I downloaded the latest version of GP Premium, deleted my old version (therefore deactivating the theme and add-ons temporarily), then reinstalled and activated the GP Theme and the GP Premium plug in and that did the trick. My site is now coming up correctly on the iPhone and iPad with no ‘undefined’ pop up error messages.

    I’m thrilled and relieved – thank you so much! 🙂

    #176733
    Tom
    Lead Developer
    Lead Developer
Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.