[Resolved] Site Library Import Not Working

Home Forums Support [Resolved] Site Library Import Not Working

Home Forums Support Site Library Import Not Working

  • This topic has 14 replies, 4 voices, and was last updated 3 years ago by Tom.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #528571
    Matthew

    Hi all,

    GP Pro noob here, and general WP noob as well.

    I bought GP Pro, excited to utilize some of the fantastic importable sites in the site library.

    The video shows all you need to do is go to Appearance->GP and Site Library is an easy to use menu option. I can’t see this at all in my current install. GP and GP Pro are installed and activated. I also have Elementor and Elementor Pro installed and activated so far, if that matters.

    Am I doing something wrong? Is the tutorial video out of date?

    Please help!

    Thank you,

    Matt

    GP Premium 1.6
    #528574
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    If GPP 1.6 is installed and you don’t see the “Site Library” menu in “Appearance > GeneratePress”, it means either:

    a) You’re not using GP 2.0.2.
    b) You’re using an old version of PHP, and should ask your host to update you to at least PHP 5.6 (PHP 7 is best).

    #529652
    Matthew

    Thank you Tom!

    I was using an out-of-date version of the plugin.

    My bad :0(

    Thanks, again!

    #529749
    Tom
    Lead Developer
    Lead Developer
    #547087
    Ross

    I have the same problem. Checked the php version through cpanel which was 7.1 I chose to go back to 7 but still cant see the site library?

    #547528
    Tom
    Lead Developer
    Lead Developer

    In that case, your server likely can’t connect to gpsites.co. You can check with your hosting to make sure your server is able to communicate with that domain.

    #547879
    Ross

    I have checked with the domain support and they can’t see anything obvious. I did the same install on another site with the same company and another one with a GoDaddy site and the same issue. Can only see GeneratePress 2.0.2 at the top with no other menu for the gpsites theme template selection. The support wanted to know what technical requirements are required so they can check out further? I can see the site with the piviot template from the Chrome browser that I want to use but no options inside the wordpress dashboard – GeneratePress – Appearance menu?

    #547970
    Tom
    Lead Developer
    Lead Developer

    The plugin uses wp_safe_remote_get() to contact gpsites.co. Once it contacts the server, a list of sites are returned, and the library is populated.

    If wp_safe_remote_get() fails and nothing is returned, then the site library simply won’t show up.

    So your hosting can simply check if wp_safe_remote_get() can reach gpsites.co.

    If there’s nothing on their side, you can send me the server IP address through our contact form (https://generatepress.com/contact) and I’ll make sure the server isn’t blocking it.

    #563884
    Enrique

    Hi Tom, I have the same Ross problem.

    I have sent you another contacto form, I hope we can solve it.

    Regards,
    Enrique

    #563962
    Tom
    Lead Developer
    Lead Developer

    Hi Enrique,

    Have you checked all of the above?

    From a technical standpoint, there’s only two things that can prevent them from showing up.

    1. PHP version
    2. No communication between servers (https://generatepress.com/forums/topic/site-library-import-not-working/#post-547970)

    #564013
    Enrique

    Hi Tom, thank you for your quick reply.

    I have already checked my PHP version. Import doesn’t work with 7.0.29, neither 7.1.16 or 7.2.4. Plugin GP Premium is up to date too, so I guess it is about point 2: no comunication between servers.

    I have been chating with my host privider (Siteground) and I have sent them this URL in order they can read your reply #547970, but they couldn’t do anything and they have suggested me to contact with you. I have sent you a contact form with my URL domain, maybe you can check if there is any problem with my domain IP.

    Regards,
    Enrique

    #564177
    Tom
    Lead Developer
    Lead Developer

    Hmm, very strange. If our server did kick out your server IP, it would only be for 5 minutes.

    Any chance you can create a staging site (https://en-ca.wordpress.org/plugins/wp-staging/) and then send me temporary admin login details for it?: https://generatepress.com/contact

    I’ll be able to run some tests to find the issue.

    #564481
    Enrique

    Hi Tom,

    Sure, I really appreciate it.
    I have just sent you a contact form with all the login data.

    Regards,
    Enrique

    #567070
    Enrique

    Hi Tom,

    I’ve checkd it out again. Now with the new versoin of the theme that you (and your team) have launched a couple days ago, I’m able to import the library on my website successfully. So I think the problem may be already solved for all sites πŸ™‚

    Thank you so much for your support, you really deserve to be the best rated theme on wordpress!

    Regards,
    Enrique

    #567433
    Tom
    Lead Developer
    Lead Developer

    Thank you! Glad it’s working now πŸ™‚

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.