[Resolved] site library – demo not imported

Home Forums Support site library – demo not imported

  • This topic has 5 replies, 2 voices, and was last updated 9 months ago by barbara.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1098152
    barbara

    Hello, I installed generatepress Version: 2.4.1 and gp premium Version: 1.9.1

    When I try to import a site from the site library I can’t import images and Elements (header, hooks etc), altough I see the changes in the interface (colors, typography, footer etc) and the plugins associated with the theme are installed.

    This happens with any theme.

    This is the error returned by my local server with easy php, it seems like I import an empty xml file:

    [Mon Dec 09 00:07:05.935883 2019] [php7:warn] [pid 18740:tid 1380] [client 127.0.0.1:51920] PHP Warning: XMLReader::read(): file:/C:/Program%20Files%20(x86)/EasyPHP-Devserver-17/eds-www/xxx/wp-content/uploads/2019/12/content-5.xml:1: parser error : Document is empty in C:\\Program Files (x86)\\EasyPHP-Devserver-17\\eds-www\\xxx\\wp-content\\plugins\\gp-premium\\sites\\libs\\wxr-importer\\WXRImporter.php on line 344, referer: http://127.0.0.1/xxx/wp-admin/themes.php?

    this is the content of xml file:

    í}{wÛ6Ò÷ßé9ÏwÀ*Û&Ù5e’ºš¾ôqsß’·Ýv÷ݳÇ!‰
    E²¼øÒœ|—ý,ûÉÞ $AŠ’EÙ²•VÙljƒÀ`0 f~€ƒï/§.9gaäøÞaÃhê
    ¼¡o;Þø°ñãé­ß ß}sð’M#§'”ð—’ŸýÐþ²(“ì1ólf“”d丌Œ™ÇBCÒàJÉHá¯GØeà‡1ñGäÊOB91kM“¼ŽÉÐ÷bêxP7òÃ)/B~ç%E$ð£8Ú!3øÏПN™‡ C¨x쇦RÏ&~<a!’
    ß•šþé’dJ¯H1c³8ë±OâzÑÊħÉ(ô§Ä÷¯³QSV(žfTà¿ð %Ù#ž3.ä5pPÐá§$¨…¤çgÊ…ÅùSÅ”ýB’p®F¾ëú›A›¢˜‘•sg4É%y±i¼ŒèjOω é±¯6Él’—>8õ}¨½ü ‘ S»ËC_xÌUJ·šäµÅÔuyöF–¿!Bærů.T¯”m7Éñ0vΡ7Éwäcâɺï4ɏëS[éÁ$‚Ë)¢¸Húçöï‰Vã€QHt›|$\8ÀäÈ £˜P(ŸD¯MiÀIÑ$žøa$5ÉAœCð1£ |!!Ñ¥/ü0:œH2;ØÝ|ì
    ‘¾±¬”T*ì„‚ÍÁ
    Tš(BöaÈP>”xì‚çQÖk*ýÛ…½tDqv`à!Áef‹‡Íkr–‚˜R™ˆ‘³r4K¥à‡‡ù8Øm7÷š ^D;ìÆ©}MßÓÌ1[–a4D!4!ÓP&h¨o€Òò”‹]YćIÖîîPrÓÇ»¢—v¦¹+3îf%å¼ÎJIèòBP”Ðw§¾¸,ڕ󒣋¼>æº8̘}Á¼øS!¾ã¯óöp¶{¸Ë\Æ%

    Can you help me?

    Thanks a lot

    #1098432
    barbara

    I add that I tried this solution but it doesn’t work for me:

    https://generatepress.com/forums/topic/import-from-site-library-but-has-no-demo-content/

    #1098957
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That topic you linked to is the only other time I’ve seen this. They reported that installing these extensions on their server worked: https://generatepress.com/forums/topic/import-from-site-library-but-has-no-demo-content/#post-932022

    I do believe the issue is that your server isn’t able to download the XML file correctly – all of those weird characters shouldn’t be there.

    Are you using shared hosting or something more advanced?

    #1108062
    barbara

    Hi Tom,

    thank you for your answer and sorry for my late feedback. It was a local installation.
    I wasn’t able to solve the problem, but I uninstalled Easyphp and with Xampp everything works.
    Thanks a lot anyway

    #1108163
    Tom
    Lead Developer
    Lead Developer

    No problem – glad you got it working 🙂

    #1108168
    barbara

    thank you

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.