[Resolved] Single post featured image

Home Forums Support Single post featured image

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #267322
    Ronald Roy

    I’m trying to control the layout of the header on a single post. To be specific, I want to have the featured image below the title. This works fine on my main blog page or a category page, but it doesn’t work on a single post.

    In a recent support forum post a user was told to set single post header position in Customizer > Layout > Page Header > Single Post Header Position > ….

    I don’t see anything for single posts when I go to Customizer > Layout > Page Header

    #267323
    Leo
    Staff
    Customer Support

    Hi Roy,

    Can you make sure you are using the most recent version of GP Premium?
    We are currently on 1.2.92

    https://docs.generatepress.com/article/updating-gp-premium/

    Let me know.

    #267337
    Ronald Roy

    Thanks for the quick reply. Yes, I’m using the latest version.

    Solved the header problem by disabling and re-enabling the GP plugin. After first installing the plugin I created a child theme and enabled it. That may have confused things. GP now gives me single post header options. I now have my featured image sitting nicely below the post title.

    One remaining problem: the featured image isn’t centred in a single post (it is centred when viewing a page of posts).

    #267338
    Leo
    Staff
    Customer Support

    Use this CSS:

    .page-header-image-single {
        text-align: center;
    }

    Adding CSS: https://docs.generatepress.com/article/adding-css/

    Let me know.

    #267547
    Ronald Roy

    Thanks. That’s the same workaround I decided on.

    Will this be fixed in the next release?

    #267552
    Leo
    Staff
    Customer Support

    This is actually not a bug – The settings in Blog > Featured Images are meant to control the blog page, not single post.

    I will ask Tom to consider setting the featured image in single post to center by default though 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.