Black Friday sale! Get up to 25% off GP Premium! Learn more ➝

[Support request] Single home page image in page header no longer showing

Home Forums Support [Support request] Single home page image in page header no longer showing

Home Forums Support Single home page image in page header no longer showing

  • This topic has 23 replies, 3 voices, and was last updated 6 years ago by Tom.
Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
  • #421884

    Hi, I normally have a single image showing in my homepage and when clicking on the image you enter the rest of the website.
    Since the latest update that image no longer shows. I had this image in the page header. It still is there, but it just won’t show anymore.
    Now you only see the footer but miss this image.
    Any ideas how to get the image back?


    I tried adding an image through the new overall page headers. But although I get the image showing in a test page, the hyperlink does not work which I add to the image in the page header. Maybe because it is a background image? Before the update all worked fine. I used to only have an image in the page header. No content. But somehow now this is changed and content must be there. When I add the “featured” image by adding {{custom_field._thumbnail_id}} in the content, the image may show but the link won’t work.
    Test page:
    Also added the image back to the homepage, but the link on the image does not work:
    When you click on the image you should go to:
    Any ideas? Thanks in advance.

    Customer Support

    Hi there,

    Page header has always required content. But it can be a space or <!--HTML comment-->.

    To achieve something like that, try this in page header content:
    <a href="https://LINK-HERE"><img src="http://IMAGE-LINK-HERE">


    Thanks for the quick response. I probably had a space in the content if there was always content.
    I tried your proposed solution, however it does not solve the issue as good as it used to be.
    I do now have an image there which can be clicked, but before the link of the background image worked also.
    The page header functionality offers to add an image and an image link. This image link simply does not work anymore. By using the image option from the page header and not putting it in the content of the page header, the image spread out nicely across the page, regardless of the size of the page.
    With the proposed solution, the link can be made, but the page no longer looks ok.
    I added some css now as well and had to remove the image which was provided via the image option, because it would result in two images.
    However, I would like to use the image option which is in the content header, and having the link option which is offered working as well, instead of adding the image in the way you proposed.
    Can you explain why the image link which is offered in the page header does not work anymore?

    Customer Support

    Huh that’s weird it’s not working for you.

    I just tried this:

    And both options are working without adding content.

    Just making sure these are the steps you are taking.

    What have you disabled in here?


    Hi Leo, thanks for helping out and showing via the video. I have these items also filled that you show.
    I have disabled Header, Primary Navigation, Secondary Navigation and Content Title. The rest is enabled.
    I have an image selected in the Image tab of the Page Header, I have an Image Link there as well. I have Resize Image Enabled and for the width and height 0 and 0.

    Customer Support

    Hmm wouldn’t resizing the image to 0 and 0 just remove the image?


    Hi Leo, below the place where you can enter the numbers it says: Use “0” or leave blank for proportional resizing.
    Even when clearing it and saving, automatically there are zeros filled in.

    Customer Support

    I think leave it for proportional sizing is when you set at least the width or height so that the other size resize accordingly.

    Can you turn off image resizing and test?


    I turned it off, however, no change. The image is not clickable.


    Hi Leo, I created a different solution so that at least the image is clickable.
    I have added some css code to the page which adds a clickable link to the entire page above the background image.
    .mb-takeover {
    position: absolute;
    display: block;
    width: 100%;
    height: 100%;
    z-index: 1;
    cursor: pointer;
    And then added the link to the Content part of the Page Header:
    Solution via this page:
    Although it does not solve the mysterie for the image link not working, for the short term this is a solution.
    So I am still interested in the proper solution, although I can imagine it is hard to track if on your end stuff is working.

    Customer Support

    Can you try turning off Add Background image?

    All you need should be to upload a featured image or custom image, then add the image link. Everything else should be off:


    I turned everything off like you showed in the video.
    The result is that no image is showing anymore.
    This is what I had before and worked before the upgrade.

    I have a test page for checking the issue because I do not want my homepage not working.
    There you can see there is no image, although one is added to the Page Header image tab.
    Over here it is now just after midnight, so I will continue tomorrow.
    Thanks for all the help.

    Customer Support

    Can you send me the admin access to your site through Account Issue here?

    Just reference this topic.



    Hi Leo, I am not sure what you mean?
    Do I need to send my admin credentials in one of the fields of the contact form for Account issues?

Viewing 15 posts - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.