[Support request] Sidebar widget not showing all entries

Home Forums Support Sidebar widget not showing all entries

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1328465
    Dee

    I have 2 Custom Post Types built in Pods: Projects and Clients

    In a Projects post, I have a sidebar widget that lists the other projects related to the same client. This post type is client facing.

    In a Clients post, I have a sidebar widget that lists all the projects for that client. This post is for my internal use.

    The list in the Projects post truncates the list to 15 posts.
    The list in the Client post lists all of the projects.

    I cannot find where the limitation is coming from in the Project posts.
    I have reviewed the Pods templates, the Elements setup, the custom css, turned plugins off, and am at a loss.

    Can you assist in pointing me in the right direction to fix this?

    I used the Flint Skin Dispatch as a basis for the site. I have WP Show Posts pro and elementor pro, but I am not using either of these 2 on the posts referenced above. I am using the Custom Sidebars plugin to change the widgets per post type, but even when I put the Pods single item widget in a regular sidebar and disable this plugin, I still get the 15 item limit.

    #1328601
    David
    Staff
    Customer Support

    Hi there,

    if an identical widget / shortcode is being used to display both lists then maybe its a caching issue – do you have any server side caches ?

    #1328732
    Dee

    It is not the exact same list, but should be the same results.
    The Project one is querying Projects related to Projects with the same Client, and the Client one is querying all projects with the same client.

    I have tested with disabling all caching plugins, then opening a different browser. I use MS Edge and Firefox for testing, and have them set up to clear the browser cache when they close.

    #1329115
    Leo
    Staff
    Customer Support

    Sounds like an issue with Custom Sidebars plugin.

    Have you checked with their support?

    #1329143
    Dee

    Yes, and since I get the same result when I disable that plugin and use the coding in the standard sidebar WITH THEIR PLUGIN DISABLED, I do not think this is the issue.

    #1329176
    Tom
    Lead Developer
    Lead Developer

    How are these lists being generated in their widgets? Is it something specific to Pods?

    #1329184
    Dee

    Yes, I have have already gone through the coding with them, so I think it might be CSS related.

    #1329213
    Leo
    Staff
    Customer Support

    What CSS are you adding?

    What if you temporarily disable all the CSS you’ve added?

    #1330438
    Dee

    I switched off my child theme with my css, and I still had the issue.

    I plan to create a separate site, and strip everything down except for the pods framework, to try to isolate the issue. I will report back here when I have completed that testing.
    I am beginning to think there is some limit in the database somehow.

    #1330452
    Leo
    Staff
    Customer Support

    Sounds good. Let us know.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.