[Support request] Sections disappeared. Sections Missing. Update did not fix.

Home Forums Support Sections disappeared. Sections Missing. Update did not fix.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #328912
    Danny

    Hi guys,

    I’ve used Sections for a long time now and love it a lot! But for some reason, all of a sudden none of my sections displayed and disappeared and were missing. I updated the plugin, and now it displays ‘No sections added’. I don’t know what else the issue might be. I’ve went through all the basic troubleshooting things and no other issues that i can see. In addition, i do not get any errors on the page at all.

    Thanks again 🙂

    GeneratePress 1.3.46
    #328915
    Leo
    Staff
    Customer Support

    Hi there,

    Hmm that’s weird. Haven’t heard this one before…

    So your content just disappeared? Can you provide a link to your site? Thanks!

    #328931
    Danny

    Thanks for the response Leo. Yes, it is http://deltautahchamber.com
    I’m looking at the database tables and it does look like the section data is still there as i can see some of the html for the main section i had on the homepage.

    #328936
    Leo
    Staff
    Customer Support

    Hmm I don’t see any obvious issue.

    What version of GP premium are you using? Is the Sections featured turn on?
    https://docs.generatepress.com/article/sections-overview/

    #328940
    Danny

    Yeah, the section toggle is on for all the pages. Using the Sections Version 1.0.26 and GeneratePress Version: 1.3.46. I am running a child theme but I’ve checked that page you have that talks about a couple things to make sure that are not called in in your stylesheet file or functions files. I’m not calling any custom style sheets using the enque thing either.

    #328950
    Leo
    Staff
    Customer Support

    Sorry I’m little confused.

    So the sections is turned on and you see some of the content there but it’s not being displayed?

    #328956
    Danny

    lol
    On the page edit screen, I have the Sections Toggle turned on and it shows the button to Add A Section. However, none of the sections that i had previously created are showing up, though i do see some database table entries via phpmyadmin for the sections that used to be associated with those pages.

    #328957
    Danny

    The previous sections i had created a long time ago don’t show up on the pages edit screen nor are they displayed on the front end.

    #329113
    Tom
    Lead Developer
    Lead Developer

    Have you tried deactivating other plugins to see if there’s some sort of conflict?

    If the Sections exists in the postmeta db table, then they should show when viewing the post.

    #329476
    Danny

    It’s kind of odd. I look into the database for one of the pages that still has the sections displaying. I see two entries related to that post id (_generate_use_sections and _generate_sections) I don’t see anything in the value itself that connects them to the post other than the actual post id. When i open to edit this page, the sections display just fine to edit and also on the frontend. But i look at the meta data for another page and it also has the same two things associated with it’s post id. But when i open that page to edit or view the frontend, it still shows no sections. Could an id or something have gotten corrupted? The post id does seem to match in the latter case just as in the former so that it should work. But a no go. Hmm got me stumped. When i opened another page with sections and toggled off sections and saved, it seems to have nuked those two _generate entries completely with the old data that i had for that page. Thanks for you ideas. Usually i do my best to troubleshoot things and can usually find the culprit but this time…. lol

    #329706
    Tom
    Lead Developer
    Lead Developer

    Is there any data inside the actual entries? It should be serialized inside the _generate_sections entry.

    #329930
    Danny

    Funny enough, yeah.

    Page ID 5 where sections work…

    _generate_use_sections

    a:1:{s:12:"use_sections";s:4:"true";}

    _generate_sections

    a:1:{s:8:"sections";a:2:{i:0;a:3:{s:16:"background_color";s:7:"#3f3f3f";s:10:"text_color";s:7:"#ffffff";s:7:"content";s:71:"<h1 style="text-align: center;">"We're Committed to Your Success."</h1>";}i:1;a:2:{s:16:"background_color";s:7:"#ffffff";s:7:"content";s:502:"The DACC is a nonprofit organization of business and professional people who seek to build a healthy, growing local economy and improve the quality of life in our community.
    
    We work with Delta City, Millard County Tourism and Economic Development and Millard County School District to promote business in our area.
    
    As a Chamber we continue to find ways to promote our local businesses. With the increased use of technology, we are able to better inform our members and highlight their businesses.";}}}

    POST ID 80 where sections don’t display. (Page just says that there are no sections)

    _generate_use_sections

    a:1:{s:12:"use_sections";s:4:"true";}

    _generate_sections

    a:1:{s:8:"sections";a:2:{i:0;a:3:{s:16:"background_color";s:7:"#3f3f3f";s:10:"text_color";s:7:"#ffffff";s:7:"content";s:60:"<h1 style="text-align: center;">"How Can We Help You?"</h1>";}i:1;a:6:{s:14:"custom_classes";s:17:"contact bg-repeat";s:11:"top_padding";s:2:"80";s:14:"bottom_padding";s:2:"80";s:16:"background_image";s:3:"166";s:15:"parallax_effect";s:6:"enable";s:7:"content";s:443:"<div class="grid-65">
    <h3>Send A Message</h3>
    [contact-form-7 id="4" title="Contact Us"]
    
    </div>
    <div class="grid-35">
    <h3>Telephone</h3>
    (435) 864-4316
    <h3>Address</h3>
    75 West Main
    Delta, Utah 84624
    
    <a href="https://goo.gl/maps/4LWConf6VE92" target="_blank"><img class="alignnone size-full wp-image-191" src="http://dev.deltautahchamber.com/wp-content/uploads/2016/02/map.png" alt="map" width="511" height="343" /></a>
    
    </div>";}}}
    #330303
    Tom
    Lead Developer
    Lead Developer

    That is super strange..

    What happens if you add that exact same content (as the problem page) in a brand new page?

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.