[Support request] Right sidebar widgets problem

Home Forums Support Right sidebar widgets problem

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #908538
    Matthew

    My Blog layout is set to Content / Sidebar (Layout > Sidebars > Blog Sidebar Layout)

    On the public page by default there is a Search box and underneath that an Archives box in this right sidebar.

    So I want to add another new item in this sidebar, an opt in form.

    I create the form in Mailerlite and it adds its widget under Appearance > Widgets which I then drag from the Available Widgets into the Right Sidebar as they instruct. But it replaces the Search field box and Archives box rather than coming in under them.

    I check Appearance > Widgets and notice the Right Sidebar area is blank, there is no Search field box and Archives box. So what are these if they are not widgets, and how can I keep them in while adding my Mailerlite sign up form.

    thankyou

    #908636
    David
    Staff
    Customer Support

    Hi there,

    WP adds those widgets automatically whenever there is an empty sidebar present. I suppose so people don’t question where my sidebar actually is 🙂 You can add those widgets manually to the sidebar, you will see them available in the widget list.

    #1066097
    Matthew

    Is it a requirement to add the Archives and Search widgets to the right sidebar, as you have said, they are already there.

    Also, when I click on a link in the archives box I am taken to the home page displaying all the latest published posts, not the posts for the month.

    This error occurs after I also added the archives widget manually.

    I want to keep these two widgets there for now, as there needs to be something in the sidebar. Or would you suggest something else? Do people tend to ditch these

    thanks,

    #1066334
    David
    Staff
    Customer Support

    It really is down to personal preference.
    If i need both those widgets in my sidebar then i will manually add them to the Sidebar widget area – instead of letting WP automatically add them solely so as i feel in control.

    Are you able to link me to the site so i can take a look at the Archive link issue?

    #1067084
    Matthew

    I edited the original topic with the URL and password there,

    thanks,

    #1067301
    David
    Staff
    Customer Support

    Hmm thats odd.
    Couple of things to try:

    1. Rebuild permanlinks – Dashboard > Settings > Permalinks and hit Save a couple of times.
    2. Edit the sidebar widgets and add the archive widget manually.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.