Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Removing widgets doesn't work on post page

Home Forums Support Removing widgets doesn't work on post page

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #331289
    Dariusz

    Hello,

    I have got 4 widgets active in footer section of the front static page.
    I have got 2 subpages with widgets switched off – working correctly.

    Now I created a post page and there the problem started.
    It keeps on showing footer widgets while they are set to 0.

    Interesting is that when clicked the post to full open widgets disappear.

    How can I remove the widgets from post page only?

    GeneratePress 1.3.47
    #331309
    Leo
    Staff
    Customer Support

    Hi there,

    By default WordPress ignores all meta boxes on index pages (blog, archive pages)

    Try this CSS to remove footer widgets:

    .blog .footer-widgets,
    .archive .footer-widgets {
        display: none;
    }

    Adding CSS: https://docs.generatepress.com/article/adding-css/

    Let me know.

    #331376
    Dariusz

    Hello Leo,

    Thank you for your prompt reply.

    I added CSS to the post page but it didn’t help.
    Same with adding to the post.

    Would be grateful for any other tips

    Best regards,

    Dariusz

    #331388
    Dariusz

    Hello Leo,

    I entered CSS using customizer option now and it worked!. Thank you for your help!

    #331651
    Leo
    Staff
    Customer Support

    Simple CSS meta box won’t work on index pages (blog) either.

    So anything for the main blog page needs to be entered in global editor.

    Glad you figured out!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.