[Resolved] Remove Sidebar on One Post

Home Forums Support Remove Sidebar on One Post

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #1449368
    Tom

    I would like to remove the sidebar on a few of my posts. I have seen references to the layout metabox, but I cannot figure out where that is or how to activate it. I have version 2.4.2 of the theme and 1.11.3 of the GP Premium plugin installed.

    Thanks

    #1449391
    Elvin
    Customer Support

    Hi Tom,

    You can set your Layout Element’s Display Rule to specific posts.

    Here’s a demo video of a Layout Element w/ no Sidebar that will only apply on “Hello world” post.
    https://share.getcloudapp.com/WnuJolRd

    Alternatively, you can edit the specific post’s Layout > Sidebar.
    https://share.getcloudapp.com/E0unx4WY

    Let us know if it works for you.

    A wise man once said:
    "Have you cleared your cache?"

    #1449399
    Tom

    Thanks, I accomplished it by using the first suggestion.
    I don’t have the layout section in the edit post page. How is that added?

    #1449423
    Elvin
    Customer Support

    Nice one,

    Perhaps the layout metabox is unchecked on your editor options.

    You can enable it here.
    https://share.getcloudapp.com/nOukGDLr

    A wise man once said:
    "Have you cleared your cache?"

    #1450067
    Tom

    I did have that option checked but it still doesn’t show the layout section in the document settings. Does that maybe need to be enabled somewhere in the GP plugin? I went through the documentation and the only thing I could find was the disable sections module, but enabling that didn’t change anything. I guess it could be a plugin conflict maybe.

    Thanks

    #1450106
    Leo
    Staff
    Customer Support

    In that case it could be plugin conflict for sure.

    Can you deactivate all plugins except GP Premium to test?

    #1454188
    Tom

    I did deactivate all the plugins and the layout section is still not showing. Is there a section of the GP plugin that needs to be enabled? I am using a child theme, could that be an issue?

    #1454209
    Leo
    Staff
    Customer Support

    Is there a section of the GP plugin that needs to be enabled?

    No there isn’t.

    I am using a child theme, could that be an issue?

    Don’t think so but it might be worth to activate the parent theme to test.

    #1454252
    Tom

    The child theme was not an issue.
    The display rule works, so unless you have another idea, we can close this issue.

    Thanks

    #1454253
    Leo
    Staff
    Customer Support

    Hmm I wouldn’t mind looking into this a bit more as it’s strange.

    Any chance you can provide the dashboard login info so I can take a look?

    Please disable all plugins if you can.

    Thanks πŸ™‚

    #1454255
    Tom

    What email should I use for the access?

    #1454264
    Leo
    Staff
    Customer Support

    You can use the Private Information box below the reply box πŸ™‚

    #1454341
    Tom

    Here is the info

    #1454345
    Leo
    Staff
    Customer Support

    Looks like it’s working for me:
    https://www.screencast.com/t/Y98j27XpZBkW

    Are you seeing something different?

    #1454354
    Tom

    It still doesn’t work for my usual account, but it works for the new account I created. Maybe my account has issues. It is an admin account. Any thoughts?

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.