Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] remove link to media file on the attachment page

Home Forums Support remove link to media file on the attachment page

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #141466
    Markus

    Hi, ist possible to remove the a href tag from an image on the attachment page.
    I want to show the images on the attachment page in original size. In the image description I put a history back link. So the link to the attachment page should be a simple enlarge function for an image and description as well.

    Any simple Idea?

    Thx
    Markus

    #141470
    Markus

    Or simply a history back link on the image instead of the link to the media file…

    #141475
    Tom
    Lead Developer
    Lead Developer

    Hi Markus,

    When you insert the image, there should be an option called “Link To” in the bottom right hand corner. It allows you to link to the attachment page, media file, custom link or nothing.

    Maybe that’s what you’re looking for?

    Let me know 🙂

    #141486
    Markus

    Hi Tom.

    No. When I upload I can say no link. But when insert the image in a page I want to link to the attachment page. BUT! When you click on the image and you are on the attachment page the link to the media file (original image) is still on the image.

    Another problem appears 🙁 when I try to ad a page header image for the attachment page – to get the same layout – the button ad image is not working. I can ad a image url in the textfield. But it’s not saved.
    Also the options for Layout,Footer Widges and deactivate Elements are not working on the attachment page.

    ?
    Markus

    #141604
    Tom
    Lead Developer
    Lead Developer

    I think that’s just the way the attachment post type operates.

    Any specific reason why you’re using the attachment page, and not just creating a custom page with the image on it? That may be your best bet.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.