[Resolved] Read More Link not working on Static Home Page Blog Section

Home Forums Support Read More Link not working on Static Home Page Blog Section

  • This topic has 9 replies, 3 voices, and was last updated 6 months ago by Tom.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1247386
    Rafael

    Hello. I recently noticed my Read More tag for blog posts from my home page which is static do not load. I initially noticed it on mobile but now I see it happening on desktop too. I think it started after I activated WP-rocket but it still happens after I deactivate it. The Read More tag seems to work fine when clicking on it from within the actual Blog page, but not when clicked from the Home page. All the read more tags display a link to /#more-2095, however when I am in the wordpress page editor, the hyperlink seems to be fine and linking to the actual blog post. I appreciate any help.

    #1248154
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can disable all plugins except GP Premium to eliminate conflicts from other plugins first?

    Let me know 🙂

    #1248168
    Rafael

    Hi Leo, I just tried that but unfortunately I still have the issue.

    #1248169
    Leo
    Staff
    Customer Support

    Are all pllugins disabled currently?

    Looks like you still have some sort of caching turned on.

    That’s also a WordPress core block – can you test if it works correctly with a twenty series WP theme?

    #1248193
    Rafael

    There are all currently disabled and I activated the twenty sixteen theme. The “Read more” works but “continue reading” does not.

    #1248202
    Leo
    Staff
    Customer Support

    Ok I think was able to replicate the read more button issue with GP.

    Can you confirm that the link works if you uncheck display as a button?

    Not sure if it’s a GP issue or Gutenberg issue but will do some digging.

    A quick workaround solution right now would be to use a plugin like WP Show Posts:
    https://en-ca.wordpress.org/plugins/wp-show-posts/

    #1248215
    Rafael

    Thanks for the responses Leo. I did as you said and disabled display read more as button within GP but I am still having the issue. At least now its not redirecting to the #more-2095 as it was before, but it just redirects back to home page.

    #1248456
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I think this is a Gutenberg bug which they’ve fixed: https://github.com/WordPress/gutenberg/pull/20541

    If you try the Gutenberg plugin it should be fixed.

    #1248522
    Rafael

    Thanks I will take a look into it. For now I have disabled content as I did not like the work around of adding another plugin since I couldn’t customize the button color for the read more link.

    #1248602
    Tom
    Lead Developer
    Lead Developer

    No problem. Hopefully it’s something that will be fixed in the next version of WordPress.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.