[Support request] Read More Button Missing on New Posts

Home Forums Support Read More Button Missing on New Posts

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1279417
    Justin

    All of sudden the read more button will disappear for new posts, on all 3 of my GeneratePress sites.
    Tried a few of the solutions in the forum:

    -I’ve tried deactivating all plugins except GP premium. Still won’t work
    -Made sure I am not using custom excerpt
    -tried adding the PHP solution for read more and read text in code snippets. Still didn’t work.

    Solution was to add the read more block in the wordpress editor. And I have to add it after the first paragraph to get an excerpt, otherwise the excerpt on the front page is the entire text of the post??

    Also if I add the read more block it overrides the custom excerpt whatever I write in there. If I remove the read more block the custom excerpt works.

    Any ideas, I don’t mind adding the read more block but it was never an issue till today for some reason.

    Also thanks for the work on this great theme, I’ve used newspaper and oceanwp and a few others and this is my favourite so far!

    #1279659
    Leo
    Staff
    Customer Support

    Hi there,

    Have you solved this?

    I can see the read more button in all the posts in the link provided.

    Let me know 🙂

    #1279770
    Justin

    Thanks for replying Leo, as I mentioned in my OP, I can solve this by adding a read more block in the wordpress editor. Which I have done this that website.

    But I usually keep a disclaimer box first, so this pops up as the excerpt if I set this as the first part of the post. I never needed to use the read more block before.

    I’ve also got this issue on my other website lazyartteacher.com I will keep the issue there for you to see.

    Please let me know and thanks.

    #1279829
    Leo
    Staff
    Customer Support

    For this post: https://lazyartteacher.com/2020/05/11/mdfdfmdndjnfdm/

    Can you make sure the existing content is longer than the word count set in the customizer?
    https://docs.generatepress.com/article/blog-content-layout/#archives

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.