[Resolved] Read More Button?

Home Forums Support Read More Button?

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1275946
    Don

    Hi,
    I am trying to get the “Read More” Button to show on my home page (that is set to latest posts) after a short excerpt like many blogs I’ve seen before. However, it only shows on the two latest posts.

    I have tried changing the number of words for the excerpt in the customizer, but that has not had any effect.

    I do not what to use the “read more tag” for each post because I would then have to go into each post and add it.

    Thank you for your help.
    Don

    #1276014
    Leo
    Staff
    Customer Support
    #1276100
    Don

    Hi Leo,
    Thank you for responding.

    I’m using the Classic Editor and I do not want to use the more tag available in each post. I have quite a few posts on this site and if I have to log into each post to add the more tag, it would be a long and arduous chore.

    I watched the video and noticed that the excerpt box in the screen options must have been removed in one of the WordPress updates since it is no longer there and the video was created in 2015.

    Currently the “Read More” button is displayed on the home page perfectly, but only for the first two posts. I have not been able to find any difference between the first two posts and the others.

    Any other ideas would be greatly appreciated.
    Don

    —-

    #1276538
    David
    Staff
    Customer Support

    Hi there.

    so looking at The Morning Mug post – this looks like a Custom Excerpt is being used? Is that correct ? If so the you need to add the PHP snippet provided here to enable the read more:

    https://docs.generatepress.com/article/activating-read-custom-excerpt/

    #1276607
    Don

    Hi David,
    Thank you for your help.

    Unfortunately, that is not true.
    I am not using a custom excerpt.
    That is what I am trying to avoid.

    I am trying to use the built-in WordPress customizer.
    I currently have the “Display Read More As Button” checked and the excerpt word count set to 95.
    I have changed the word count numerous times both up and down, but the changes only effect the first two posts.

    Any help or ideas are appreciated.
    Don

    #1276931
    Leo
    Staff
    Customer Support

    If you are sure that the custom excerpt metabox is empty, can you disable all plugins except GP Premium to eliminate any plugin conflicts?

    #1276955
    Don

    Hi Leo,
    Thanks again for your help.

    I have disabled all of the plugins except Generate Press but the read more button still only shows on the first two posts.

    Looking forward to your reply.

    Don

    #1276996
    Leo
    Staff
    Customer Support

    Are the first two posts newly created after the theme switch? If so your previous theme must have done something to it.

    What happens when you create another new post? I assume the read more button works normally?

    #1277032
    Don

    Hi again Leo,
    You may be on to something.

    I just create 2 new posts and they both show the Read More Button as desired, so it now shows on the latest 4 posts.

    Considering this, I don’t know if there’s a fix.
    I may have to go back to the previous theme (or choose another one).

    Don

    #1277045
    Leo
    Staff
    Customer Support

    Can you send me the dashboard access to take a quick look?

    Please disable all plugins except GP Premium

    You can send the dashboard access using Account Issue here:
    https://generatepress.com/contact/

    Please include the following information:
    – The URL of this topic.
    – Login URL.
    – Username and password.

    #1277101
    Don

    Dashboard access Sent

    #1277279
    Leo
    Staff
    Customer Support

    Unfortunately, that is not true.
    I am not using a custom excerpt.

    You are actually using the custom excerpt for the posts that aren’t working:
    https://www.screencast.com/t/DwkEC1NYYUW

    Remove that then the default read more button should show.

    #1277750
    Don

    OMG!

    First, let me say I’m so sorry and
    second, let me say thank you for all your help to resolve the issue.

    In my defense, I did not know that was there, probably because I do not use the Gutenburg editor and as you may know, the excerpt you pointed out in the sidebar, does not show in the Classic editor, but only in the Gutenburg editor.

    Thanks again Leo. You’re Awesome!
    Don

    #1278045
    Leo
    Staff
    Customer Support
Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.