[Resolved] Rank Math & H1 and H2 tags

Home Forums Support Rank Math & H1 and H2 tags

  • This topic has 7 replies, 3 voices, and was last updated 4 months ago by David.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1508527
    Janine

    Hi.

    I installed Rank Math yesterday. And it seems that my H1 & H2 are not being added. I have included a link with a snapshot of the error in Rank Math.

    How can I resolve this?

    Thank you.

    #1508563
    Elvin
    Staff
    Customer Support

    Hi,

    Try Leo’s answers here:
    https://generatepress.com/forums/topic/h1-tag-missing-from-homepage/#post-1310369

    Let us know if you need further help.

    A wise man once said:
    "Have you cleared your cache?"

    #1508607
    Janine

    Thanks, Elvin. I will check out the information you sent.

    #1508630
    Elvin
    Staff
    Customer Support

    No problem. 🙂

    A wise man once said:
    "Have you cleared your cache?"

    #1509218
    Janine

    Okay, I read the thread on this subject and I still don’t get it.

    Which is correct?

    LEO…

    CSS cannot turn something into an <h1>.

    The issue here is that there isn’t an element that is suitable to be <h1> on the home page. To be honest I don’t think it’s a big deal nowadays.

    If you really want to add an <h1>, then you can try creating a header element with something like this as the content:

    <h1>Blog</h1>

    QUESTION: Would this be the correct element for me? <h1>Stitching in Colour</h1>

    TOM…

    If you’re not using a site title, you can add an H1 to the posts page quite easily:

    1. Create a Hook Element: https://docs.generatepress.com/article/hooks-element-overview/

    2. Add your content:

    3. Add it to the “generate_before_main_content” hook.

    4. Set the Display Rules to “Front Page” if your blog is your front page. If not, set it to “Blog”.

    ANIL…

    I learned as follows

    add

    <h1 style=”display:none”>Your title here</h1>

    with hook on home page only.

    That’s it.

    2 years before I pointed out this issue, can any gp version would update this? I believe one line of option in customizer would solve this for newer users.

    QUESTION: What does “display: none” do here?

    Which one?

    QUESTION: And finally, shouldn’t this be in effect on ALL posts and pages on a site?

    #1509767
    David
    Staff
    Customer Support

    Hi there,

    your site is using a static page for the home page, which is different to the issues listed in that other topic. Your sites problem is because the Content Title would have been disabled in the Editor.

    To rectify that simple re-enable the Title in the editor for the home page.
    And if you want to remove it from being displayed add this CSS:

    .home .entry-title {
        display: none;
    }

    You don’t need to apply this to your other pages as it looks as though the Title is being displayed there.

    If your seeing other errors related to H2’s on any pages, that will be because you have not used any in your content.

    #1509882
    Janine

    Hi, David.

    That worked. Thanks.

    #1509903
    David
    Staff
    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.