[Support request] Qubely Plugin not Working with GP Grids or Containers

Home Forums Support Qubely Plugin not Working with GP Grids or Containers

  • This topic has 12 replies, 4 voices, and was last updated 4 months ago by Tom.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1404523
    Heidi

    I am using the Qubely plugin (free one first and then the pro) and I cannot some of the features to work in a GP plugin container or grid. I’m not sure if this is the right place to post things about the GP plugin or not and I apologize if it’s not.

    This page has the animated headline right under the header image. It is supposed to keep changing the middle word that is multicolored. It just sits there with the cursor to the right of the word.
    I have put the animated headline at the very bottom of the post as well (not in a grid or container) so you can see what it should look like and that it works fine.
    https://theunexpectedhomeschooler.com/workbox-system

    This page has animated lists and a button.
    https://theunexpectedhomeschooler.com/workbox-guide
    The top two bullet points should have check marks with circles around then instead of a plain bullet points.
    The second set is supposed to have stars instead of bullet points.
    The button has white text that is not showing up.

    Everything shows up on the backend but not in preview or after publishing.
    I updated the GP plugin yesterday and also WP to 5.5 so I don’t know if either of those are the issue.

    I don’t know a lot about web site building so if possible, please explain things in an easy to understand way.

    #1404861
    David
    Staff
    Customer Support

    Hi there,

    checking your first link i can see the animated headline working under the Discover title – which is all inside a GB Container Block – did you resolve this?

    The other link is coming up as Not Found ?

    let me know.

    #1405510
    Heidi

    I have no idea how that is working. I worked with a tech person and also Qubely’s support and none of them could get it to work. But glad it is! 😁

    Here’s the url for the page that said Not Found. I hadn’t published it yet because of the issues but went ahead and did it so you can see it.
    https://theunexpectedhomeschooler.com/workbox-guide
    It still have the same issues as what I’ve listed above.

    Thank you so much for taking a look at these!

    #1405511
    Heidi

    Also, I just discovered that the animated headline isn’t completely fixed. If I remove the sample one at the bottom of the page, the one at the top stops working.

    #1406099
    David
    Staff
    Customer Support

    I can only assume that the animated heading plugin is only scanning their own / core blocks to see if a animated heading exists. Have you spoken with their support regarding this ?

    #1406507
    Heidi

    I am trying to work with them. This is the response I got:

    I tested both animated headline and advanced list blocks on a default WordPress theme with the latest version of WordPress. They both appear functional and I was able to to change icons and new icons appeared on the frontend as shown in the following images
    https://www.dropbox.com/s/0iwxua7yi7gcy1d/Screenshot%202020-08-15%2010.59.57.png?dl=0
    https://www.dropbox.com/s/ni7r5qkubt9yt49/Screenshot%202020-08-15%2011.03.50.png?dl=0

    You can troubleshoot the issue by switching to a default WordPress theme to see if the blocks function as expected.

    You can go to Qubely Global Settings to switch between Qubely or your theme’s preset to see if it resolves the issue.
    https://www.dropbox.com/s/tbqpm0w2tpig6ye/Screenshot%202020-08-15%2011.05.03.png?dl=0

    You can also change from your theme’s default template to qubely canvas or qubely full width.
    https://www.dropbox.com/s/5ccgcngrqse4wnp/Screenshot%202020-08-15%2011.05.16.png?dl=0

    Please make sure you are using latest version of PHP.

    I obviously don’t want to switch themes. The issue is when they are in a GenerateBlock plugin container or grid.

    Were you able to look at the other page I mentioned? https://theunexpectedhomeschooler.com/workbox-guide
    I was able to get the bullet points to show the icons because I have the exact same block outside the container but hidden on my site.
    I wasn’t able to get the button to show the text either way. I had to change it to an outlined one.
    Do you still think it’s on their end or an issue with the container and grids in the GenerateBlocks plugin?

    #1406844
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Also, I just discovered that the animated headline isn’t completely fixed. If I remove the sample one at the bottom of the page, the one at the top stops working.

    This tells me that the feature uses javascript, and that their plugin is looking for the feature to be active in order to add the javascript (which is good). However, they obviously aren’t looking deep enough to find the feature, as the necessary javascript isn’t loading unless the feature is used elsewhere outside of a nested block.

    I’m assuming it’s the same kind of issue with the bullet points. If you’re having to add hidden elements in order for the plugin to pick up on certain options, they likely need to address how they’re finding these options are active on the page.

    GenerateBlocks isn’t doing anything special when it comes to its blocks – everything should be discoverable without any issues.

    #1411518
    Heidi

    Thanks Tom! Yes, it’s the same issue with the bullet points, but not with the button. I will try to pass this info along to them so see if they can make an update.

    Thank you!

    #1411832
    Tom
    Lead Developer
    Lead Developer
    #1515640
    Tom

    Hey guys, sorry to reopen this thread… but something similar on my web too.

    Looks like I can’t put any Qubely blocks into GeneratePress Container… Please have a look on the screen recording: PLAY. The interesting fact – when I duplicate block and paste without GP container – everything works fine (even in container)… so looks like CSS are not rendering properly. Anyone had similar issue? Looking for solution/fix?

    #1516597
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    It looks like their plugin isn’t able to see their block on the front-end when it’s inside our Container, so the CSS isn’t being generated.

    This may be a limitation of how their CSS is generated on the frontend – perhaps they’re assuming it will be the top-level block?

    Does it work inside the core Group block?

    #1516601
    Tom

    I didn’t check. For sure it works in their row block… no issues… so at the moment I’m using their rows whenever I need to use qubely block… waiting for their support to move (3 letters) and fix that

    #1516846
    Tom
    Lead Developer
    Lead Developer

    I’m assuming they’re checking their own blocks for inner blocks. However, it’s possible they’re not doing the same for other blocks (like our Container).

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.